summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/irssi')
-rw-r--r--net-irc/irssi/ChangeLog9
-rw-r--r--net-irc/irssi/files/irssi-0.8.12-svn-4627.patch18
-rw-r--r--net-irc/irssi/irssi-0.8.12.ebuild5
3 files changed, 29 insertions, 3 deletions
diff --git a/net-irc/irssi/ChangeLog b/net-irc/irssi/ChangeLog
index bdcb01f2438f..5e198c69c86c 100644
--- a/net-irc/irssi/ChangeLog
+++ b/net-irc/irssi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/irssi
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.130 2007/12/04 20:50:45 jer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/ChangeLog,v 1.131 2008/01/20 23:09:38 swegener Exp $
+
+ 20 Jan 2008; Sven Wegener <swegener@gentoo.org>
+ +files/irssi-0.8.12-svn-4627.patch, irssi-0.8.12.ebuild:
+ Include a patch from upstream to fix a rare segmentation fault, notification
+ by Phil Sutter via mail.
04 Dec 2007; Jeroen Roovers <jer@gentoo.org> irssi-0.8.12.ebuild:
Stable for HPPA too.
diff --git a/net-irc/irssi/files/irssi-0.8.12-svn-4627.patch b/net-irc/irssi/files/irssi-0.8.12-svn-4627.patch
new file mode 100644
index 000000000000..046a1c207fa9
--- /dev/null
+++ b/net-irc/irssi/files/irssi-0.8.12-svn-4627.patch
@@ -0,0 +1,18 @@
+r4627 | exg | 2007-10-22 13:27:56 +0000 (Mon, 22 Oct 2007) | 3 lines
+
+Handle server == NULL case in skip_target, fix regression with irssi-icb.
+Patch by Stuart Henderson, bug #539.
+
+Index: trunk/src/fe-common/irc/fe-irc-messages.c
+===================================================================
+--- trunk/src/fe-common/irc/fe-irc-messages.c (revision 4626)
++++ trunk/src/fe-common/irc/fe-irc-messages.c (revision 4627)
+@@ -44,7 +44,7 @@
+ const char *val, *chars;
+
+ /* Quick check */
+- if (server->prefix[(int)(unsigned char)*target] == 0)
++ if (server == NULL || server->prefix[(int)(unsigned char)*target] == 0)
+ return target;
+
+ /* Hack: for bahamut 1.4 which sends neither STATUSMSG nor
diff --git a/net-irc/irssi/irssi-0.8.12.ebuild b/net-irc/irssi/irssi-0.8.12.ebuild
index 1bc08440a33d..107320e7f291 100644
--- a/net-irc/irssi/irssi-0.8.12.ebuild
+++ b/net-irc/irssi/irssi-0.8.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.12.ebuild,v 1.7 2008/01/13 09:01:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.12.ebuild,v 1.8 2008/01/20 23:09:38 swegener Exp $
inherit perl-module eutils
@@ -26,8 +26,11 @@ RDEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
+ cd "${S}"
epunt_cxx
+
+ epatch "${FILESDIR}"/${P}-svn-4627.patch
}
src_compile() {