summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/jreen/jreen-9999.ebuild')
-rw-r--r--net-libs/jreen/jreen-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/jreen/jreen-9999.ebuild b/net-libs/jreen/jreen-9999.ebuild
new file mode 100644
index 000000000000..7a6e9faf7ee3
--- /dev/null
+++ b/net-libs/jreen/jreen-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/jreen/jreen-9999.ebuild,v 1.1 2011/11/12 19:18:02 dilfridge Exp $
+
+EAPI=4
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://dev.gentoo.org/~jmbsvicetto/distfiles/snapshots/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ GIT_ECLASS="git-2"
+ EGIT_REPO_URI="git://github.com/euroelessar/jreen.git"
+ KEYWORDS=""
+fi
+
+inherit qt4-r2 cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Qt XMPP library"
+HOMEPAGE="https://github.com/euroelessar/jreen"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ >=app-crypt/qca-2.0.3
+ >=net-dns/libidn-1.20
+ >=x11-libs/qt-core-4.6.0
+ >=x11-libs/qt-gui-4.6.0
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/"${PN}"