summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/x2goclient/ChangeLog8
-rw-r--r--net-misc/x2goclient/x2goclient-3.99.2.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/net-misc/x2goclient/ChangeLog b/net-misc/x2goclient/ChangeLog
index 3fb9318adef9..98804553fee9 100644
--- a/net-misc/x2goclient/ChangeLog
+++ b/net-misc/x2goclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/x2goclient
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.11 2012/07/10 14:19:01 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.12 2012/08/21 23:07:46 voyageur Exp $
+
+*x2goclient-3.99.2.2 (21 Aug 2012)
+
+ 21 Aug 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ +x2goclient-3.99.2.2.ebuild:
+ Version bump
*x2goclient-3.99.2.1 (10 Jul 2012)
diff --git a/net-misc/x2goclient/x2goclient-3.99.2.2.ebuild b/net-misc/x2goclient/x2goclient-3.99.2.2.ebuild
new file mode 100644
index 000000000000..7a570a82bdae
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-3.99.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-3.99.2.2.ebuild,v 1.1 2012/08/21 23:07:46 voyageur Exp $
+
+EAPI=4
+inherit eutils qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND="net-libs/libssh
+ net-print/cups
+ x11-libs/qt-core:4[ssl]
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ make_desktop_entry ${PN} "X2go client" ${PN} "Network"
+}