summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/hellanzb/ChangeLog10
-rw-r--r--net-nntp/hellanzb/files/hellanzb-0.13-gettinggroup.patch14
-rw-r--r--net-nntp/hellanzb/hellanzb-0.13-r7.ebuild62
3 files changed, 85 insertions, 1 deletions
diff --git a/net-nntp/hellanzb/ChangeLog b/net-nntp/hellanzb/ChangeLog
index 76acf5724ace..67fe0c548ff8 100644
--- a/net-nntp/hellanzb/ChangeLog
+++ b/net-nntp/hellanzb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-nntp/hellanzb
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/hellanzb/ChangeLog,v 1.8 2008/06/18 14:05:56 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/hellanzb/ChangeLog,v 1.9 2008/08/30 20:16:02 aballier Exp $
+
+*hellanzb-0.13-r7 (30 Aug 2008)
+
+ 30 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/hellanzb-0.13-gettinggroup.patch, +hellanzb-0.13-r7.ebuild:
+ Different patch for bug #224945: use thereceived group from the server
+ instead of the group asked, so that it does not fail if there are spaces
+ in the group name or if the group changes.
*hellanzb-0.13-r6 (18 Jun 2008)
diff --git a/net-nntp/hellanzb/files/hellanzb-0.13-gettinggroup.patch b/net-nntp/hellanzb/files/hellanzb-0.13-gettinggroup.patch
new file mode 100644
index 000000000000..2f7af1ad1a96
--- /dev/null
+++ b/net-nntp/hellanzb/files/hellanzb-0.13-gettinggroup.patch
@@ -0,0 +1,14 @@
+diff -r 92936345c3f5 Hellanzb/NZBLeecher/Protocol.py
+--- a/Hellanzb/NZBLeecher/Protocol.py Mon Aug 18 10:38:55 2008 +0200
++++ b/Hellanzb/NZBLeecher/Protocol.py Mon Aug 18 11:34:20 2008 +0200
+@@ -655,7 +655,7 @@
+ reactor.callInThread(decode, segment)
+
+ def gotGroup(self, group):
+- group = group[3]
++ group = self.gettingGroup
+ self.activeGroups.append(group)
+ self.gettingGroup = None
+ debug(str(self) + ' got GROUP: ' + group)
+
+
diff --git a/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild b/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild
new file mode 100644
index 000000000000..92862b80fb5b
--- /dev/null
+++ b/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild,v 1.1 2008/08/30 20:16:02 aballier Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Retrieves and processes .nzb files"
+HOMEPAGE="http://www.hellanzb.com/"
+SRC_URI="http://www.hellanzb.com/distfiles/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify ssl"
+
+RDEPEND=">=dev-python/twisted-2.0
+ dev-python/twisted-web
+ || ( app-arch/unrar
+ app-arch/rar )
+ app-arch/par2cmdline
+ ssl? ( dev-python/pyopenssl )
+ libnotify? ( dev-python/notify-python )"
+
+DEPEND=""
+
+DOCS="CHANGELOG CREDITS PKG-INFO README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-datafiles.patch"
+ epatch "${FILESDIR}/${P}-Fix_conf_file_search_path.patch"
+ epatch "${FILESDIR}/${P}-Choose_interface_to_bind_on.patch"
+ epatch "${FILESDIR}/${P}-fix_multiples_hosts.diff"
+ epatch "${FILESDIR}/${P}-gettinggroup.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ newconfd "${FILESDIR}/hellanzb.conf" hellanzb
+ newinitd "${FILESDIR}/hellanzb.init" hellanzb
+
+ insinto etc
+ doins etc/hellanzb.conf.sample
+}
+
+pkg_postinst() {
+ elog "You can start hellanzb in the background automatically by using"
+ elog "the init-script. To do this, add it to your default runlevel:"
+ elog ""
+ elog " rc-update add hellanzb default"
+ elog ""
+ elog "Use this command to start the daemon now:"
+ elog ""
+ elog " /etc/init.d/hellanzb start"
+ elog ""
+ elog "You will have to config /etc/conf.d/hellanzb before the init-script"
+ elog "will work. It is recommended that you change the user under which"
+ elog "the daemon will run."
+}