summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gwave/gwave-20051222.ebuild')
-rw-r--r--sci-electronics/gwave/gwave-20051222.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-electronics/gwave/gwave-20051222.ebuild b/sci-electronics/gwave/gwave-20051222.ebuild
new file mode 100644
index 000000000000..b3f017553d12
--- /dev/null
+++ b/sci-electronics/gwave/gwave-20051222.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gwave/gwave-20051222.ebuild,v 1.1 2006/07/08 08:37:47 calchan Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A waveform viewer analog data, such as SPICE simulations."
+LICENSE="GPL-2"
+HOMEPAGE="http://www.geda.seul.org/tools/gwave/"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+SLOT="0"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-util/guile-1.6.3
+ >=x11-libs/guile-gtk-1.2.0.31"
+
+src_compile() {
+ filter-ldflags -Wl,--as-needed --as-needed
+ econf || die "econf failed"
+ make || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ rm -f doc/Makefile* *.1 || die "removing Makefile failed"
+ dodoc AUTHORS NEWS README TODO doc/* || die "dodoc failed"
+}