summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dcron/dcron-2.7-r9.ebuild')
-rw-r--r--sys-apps/dcron/dcron-2.7-r9.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/dcron/dcron-2.7-r9.ebuild b/sys-apps/dcron/dcron-2.7-r9.ebuild
new file mode 100644
index 000000000000..8f46fde5d63d
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.7-r9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r9.ebuild,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+# to use this, you must be part of the "cron" group
+
+S=${WORKDIR}/dcron
+DESCRIPTION="A cute little cron from Matt Dillon"
+SRC_URI="http://apollo.backplane.com/FreeSrc/dcron27.tgz"
+HOMEPAGE="http://apollo.backplane.com"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ sys-apps/cronbase
+ virtual/mta"
+PROVIDE="virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff || die
+ # fix 'crontab -e' to look at $EDITOR and not $VISUAL
+ cp ${S}/crontab.c ${S}/crontab.c.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.c.orig > ${S}/crontab.c
+ cp ${S}/crontab.1 ${S}/crontab.1.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.1.orig > ${S}/crontab.1
+ # fix for lines starting with whitespace
+ patch -p0 < ${FILESDIR}/${P}-whitespace.diff || die
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+
+ diropts -m 0750 -o root -g cron
+ dodir /var/spool/cron/crontabs
+
+ dodir /usr/{sbin,bin}
+ install -o root -g wheel -m 0700 crond ${D}/usr/sbin
+ install -o root -g cron -m 4750 crontab ${D}/usr/bin
+
+ dodoc CHANGELOG README
+ doman crontab.1 crond.8
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dcron.rc6 dcron
+
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ dodoc ${FILESDIR}/crontab
+}
+
+
+pkg_postinst() {
+
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+
+}