summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog6
-rw-r--r--sys-apps/coreutils/Manifest7
-rw-r--r--sys-apps/coreutils/coreutils-5.0-r1.ebuild5
-rw-r--r--sys-apps/coreutils/files/coreutils-5.0-confdir3.patch11
4 files changed, 24 insertions, 5 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index a01c32bb8276..5c4da38f6d1e 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.16 2003/07/28 09:13:37 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.17 2003/08/01 16:46:30 agriffis Exp $
+
+ 01 Aug 2003; Aron Griffis <agriffis@gentoo.org> coreutils-5.0-r1.ebuild,
+ files/coreutils-5.0-confdir3.patch:
+ Fix bug 25702 by refraining from cleaning up PATH_MAX test
*coreutils-5.0-r1 (28 Jul 2003)
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 6ff74561ba98..e6ae5309de1b 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -1,7 +1,8 @@
-MD5 e2d82516519685a12e01be81fb237ec4 ChangeLog 2645
MD5 3ba942f3d52e41ae12fc683369efaf04 coreutils-4.5.11-r1.ebuild 2512
+MD5 71b71aaf5afb706c69ed2a8b036fd031 coreutils-5.0-r1.ebuild 2749
+MD5 610a79f61b5abdac79641dbcf3a5577a ChangeLog 2822
MD5 1c6a1be812010048403c6e96ab21c749 coreutils-5.0.ebuild 2471
-MD5 e43c4d4c20b7c6f205ac66cb81759599 coreutils-5.0-r1.ebuild 2649
+MD5 76dc0283e4ab80294d556234c0a2c5cb files/coreutils-5.0-confdir3.patch 326
MD5 0ff5f66b1d04c85d2434fa73547e67f3 files/digest-coreutils-4.5.11-r1 207
-MD5 1f151a22e3adc814c28d4b8a54a094a5 files/digest-coreutils-5.0 273
MD5 7a78fa60b41fcc662f817573cffbebbb files/digest-coreutils-5.0-r1 213
+MD5 1f151a22e3adc814c28d4b8a54a094a5 files/digest-coreutils-5.0 273
diff --git a/sys-apps/coreutils/coreutils-5.0-r1.ebuild b/sys-apps/coreutils/coreutils-5.0-r1.ebuild
index 2032b265cf3f..25bb436b12d6 100644
--- a/sys-apps/coreutils/coreutils-5.0-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0-r1.ebuild,v 1.1 2003/07/28 06:44:50 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0-r1.ebuild,v 1.2 2003/08/01 16:46:30 agriffis Exp $
inherit eutils
@@ -41,6 +41,9 @@ src_unpack() {
then
epatch ${WORKDIR}/${PN}-gentoo-patches/${PN}-gentoo-uname.patch
fi
+
+ # Fix confdir3 sandbox issue reported in bug 25702
+ epatch ${FILESDIR}/${PN}-5.0-confdir3.patch
}
src_compile() {
diff --git a/sys-apps/coreutils/files/coreutils-5.0-confdir3.patch b/sys-apps/coreutils/files/coreutils-5.0-confdir3.patch
new file mode 100644
index 000000000000..c3405e35f9fa
--- /dev/null
+++ b/sys-apps/coreutils/files/coreutils-5.0-confdir3.patch
@@ -0,0 +1,11 @@
+--- configure.old 2003-04-02 09:28:50.000000000 -0500
++++ configure 2003-08-01 12:36:15.000000000 -0400
+@@ -27887,6 +27887,8 @@
+ break;
+ }
+
++ exit (fail);
++
+ /* Leaving behind such a deep directory is not polite.
+ So clean up here, right away, even though the driving
+ shell script would also clean up. */