summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/libcircle/ChangeLog9
-rw-r--r--sys-cluster/libcircle/files/libcircle-0.1.0_rc1-out-of-source.patch18
-rw-r--r--sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild (renamed from sys-cluster/libcircle/libcircle-0.1.0_rc1.ebuild)11
3 files changed, 12 insertions, 26 deletions
diff --git a/sys-cluster/libcircle/ChangeLog b/sys-cluster/libcircle/ChangeLog
index 987f2d0e170e..b6925249bcc6 100644
--- a/sys-cluster/libcircle/ChangeLog
+++ b/sys-cluster/libcircle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/libcircle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libcircle/ChangeLog,v 1.3 2014/01/19 19:27:26 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libcircle/ChangeLog,v 1.4 2014/03/17 19:04:20 ottxor Exp $
+
+*libcircle-0.2.0_rc1 (17 Mar 2014)
+
+ 17 Mar 2014; Christoph Junghans <ottxor@gentoo.org>
+ +libcircle-0.2.0_rc1.ebuild, -files/libcircle-0.1.0_rc1-out-of-source.patch,
+ -libcircle-0.1.0_rc1.ebuild:
+ version bump
19 Jan 2014; Christoph Junghans <ottxor@gentoo.org>
libcircle-0.1.0_rc1.ebuild:
diff --git a/sys-cluster/libcircle/files/libcircle-0.1.0_rc1-out-of-source.patch b/sys-cluster/libcircle/files/libcircle-0.1.0_rc1-out-of-source.patch
deleted file mode 100644
index 0c16d696bcce..000000000000
--- a/sys-cluster/libcircle/files/libcircle-0.1.0_rc1-out-of-source.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -Naur libcircle-0.1.0-rc.1.orig/tests/Makefile.am libcircle-0.1.0-rc.1/tests/Makefile.am
---- libcircle-0.1.0-rc.1.orig/tests/Makefile.am 2014-01-17 18:46:07.437596745 -0700
-+++ libcircle-0.1.0-rc.1/tests/Makefile.am 2014-01-17 18:58:12.495865632 -0700
-@@ -1,10 +1,10 @@
- TESTS = check_queue #check_checkpoint
- check_PROGRAMS = check_queue #check_checkpoint
-
--check_queue_SOURCES = check_queue.c $(top_builddir)/libcircle.h
--check_queue_CFLAGS = -I$(top_builddir)/libcircle/ @CHECK_CFLAGS@
-+check_queue_SOURCES = check_queue.c $(top_srcdir)/libcircle.h
-+check_queue_CFLAGS = -I$(top_srcdir)/libcircle/ @CHECK_CFLAGS@
- check_queue_LDADD = $(top_builddir)/libcircle.la @CHECK_LIBS@
-
--#check_checkpoint_SOURCES = check_checkpoint.c $(top_builddir)/libcircle.h
--#check_checkpoint_CFLAGS = -I$(top_builddir)/libcircle/ @CHECK_CFLAGS@
-+#check_checkpoint_SOURCES = check_checkpoint.c $(top_srcdir)/libcircle.h
-+#check_checkpoint_CFLAGS = -I$(top_srcdir)/libcircle/ @CHECK_CFLAGS@
- #check_checkpoint_LDADD = $(top_builddir)/libcircle.la @CHECK_LIBS@
diff --git a/sys-cluster/libcircle/libcircle-0.1.0_rc1.ebuild b/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild
index cc721b731fd3..eec347442174 100644
--- a/sys-cluster/libcircle/libcircle-0.1.0_rc1.ebuild
+++ b/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libcircle/libcircle-0.1.0_rc1.ebuild,v 1.3 2014/01/19 19:27:26 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild,v 1.1 2014/03/17 19:04:20 ottxor Exp $
EAPI=5
@@ -11,9 +11,8 @@ if [ "${PV}" = "9999" ]; then
inherit git-2
KEYWORDS=""
else
- [[ ${PV} = *rc* ]] && MY_PV="${PV%%_rc*}-rc.${PV#*_rc}" || MY_PV="${PV}"
inherit vcs-snapshot
- SRC_URI="https://github.com/hpc/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/hpc/${PN}/archive/${PV/_rc/-rc.}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -29,14 +28,12 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( dev-libs/check )"
-PATCHES=( "${FILESDIR}/${P}-out-of-source.patch" )
-AUTOTOOLS_AUTORECONF=1
DOCS=( HACKING.md README.md )
src_configure() {
local myeconfargs=(
- $(usex test '--enable-tests' '')
- $(usex doc '--enable-doxygen' '')
+ $(use_enable test tests)
+ $(use_enable doc doxygen)
)
autotools-utils_src_configure
}