summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/freebsd-usbin/files/freebsd-usbin-nowrap.patch')
-rw-r--r--sys-freebsd/freebsd-usbin/files/freebsd-usbin-nowrap.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-usbin/files/freebsd-usbin-nowrap.patch b/sys-freebsd/freebsd-usbin/files/freebsd-usbin-nowrap.patch
new file mode 100644
index 000000000000..f01d6e2b9690
--- /dev/null
+++ b/sys-freebsd/freebsd-usbin/files/freebsd-usbin-nowrap.patch
@@ -0,0 +1,46 @@
+diff -ur usr.sbin/rpcbind/Makefile usr.sbin-nowrap/rpcbind/Makefile
+--- usr.sbin/rpcbind/Makefile 2003-04-04 17:49:18 +0000
++++ usr.sbin-nowrap/rpcbind/Makefile 2005-06-20 14:15:59 +0000
+@@ -13,9 +13,19 @@
+ rpcb_svc.c rpcb_svc_com.c security.c warmstart.c util.c \
+ rpc_generic.c
+
+-CFLAGS+= -I${LIBCRPCDIR} -I${LIBCINCLUDE} -DPORTMAP -DINET6 -DLIBWRAP
++CFLAGS+= -I${LIBCRPCDIR} -I${LIBCINCLUDE} -DPORTMAP
+
+-DPADD= ${LIBWRAP} ${LIBUTIL}
+-LDADD= -lwrap -lutil
++DPADD= ${LIBUTIL}
++LDADD= -lutil
++
++.if !defined(NO_WRAP)
++CFLAGS+= -DLIBWRAP
++DPADD+= ${LIBWRAP}
++LDADD+= -lwrap
++.endif
++
++.if !defined(NOINET6)
++CFLAGS+= -DINET6
++.endif
+
+ .include <bsd.prog.mk>
+diff -ur usr.sbin/ypserv/Makefile usr.sbin-nowrap/ypserv/Makefile
+--- usr.sbin/ypserv/Makefile 2003-04-04 17:49:20 +0000
++++ usr.sbin-nowrap/ypserv/Makefile 2005-06-20 14:17:41 +0000
+@@ -8,10 +8,13 @@
+ SRCS= yp_svc.c yp_server.c yp_dblookup.c yp_dnslookup.c \
+ ypxfr_clnt.c yp.h yp_main.c yp_error.c yp_access.c yp_svc_udp.c
+
+-CFLAGS+= -DDB_CACHE -DTCP_WRAPPER -I.
++CFLAGS+= -DDB_CACHE -I.
+
+-DPADD= ${LIBWRAP}
+-LDADD= -lwrap
++.if !defined(NO_WRAP)
++CFLAGS+= -DTCP_WRAPPER
++DPADD+= ${LIBWRAP}
++LDADD+= -lwrap
++.endif
+
+ CLEANFILES= yp_svc.c ypxfr_clnt.c yp.h
+