summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/mips-sources/mips-sources-2.6.8.1.ebuild')
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.6.8.1.ebuild108
1 files changed, 0 insertions, 108 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-2.6.8.1.ebuild b/sys-kernel/mips-sources/mips-sources-2.6.8.1.ebuild
deleted file mode 100644
index a2661a865d24..000000000000
--- a/sys-kernel/mips-sources/mips-sources-2.6.8.1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.8.1.ebuild,v 1.1 2004/08/15 03:59:03 kumba Exp $
-
-
-# Version Data
-OKV=${PV/_/-}
-CVSDATE="20040814"
-COBALTPATCHVER="1.6"
-SECPATCHVER="1.2"
-IP32DIFFDATE="20040402"
-EXTRAVERSION=".$(echo ${OKV} | cut -d. -f4)-mipscvs-${CVSDATE}"
-KV="${OKV}${EXTRAVERSION}"
-
-# Miscellaneous stuff
-S=${WORKDIR}/linux-${OKV}-${CVSDATE}
-
-# Eclass stuff
-ETYPE="sources"
-inherit kernel eutils
-
-
-# INCLUDED:
-# 1) linux sources from kernel.org
-# 2) linux-mips.org CVS snapshot diff from 14 Aug 2004
-# 3) Patch to fix an O2 compile-time error
-# 4) Iluxa's minimal O2 Patchset
-# 5) Security fixes
-# 6) Patches for Cobalt support
-
-
-DESCRIPTION="Linux-Mips CVS sources for MIPS-based machines, dated ${CVSDATE}"
-SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2
- mirror://gentoo/mipscvs-${OKV}-${CVSDATE}.diff.bz2
- mirror://gentoo/cobalt-patches-26xx-${COBALTPATCHVER}.tar.bz2
- mirror://gentoo/ip32-iluxa-minpatchset-${IP32DIFFDATE}.diff.bz2
- mirror://gentoo/${PN}-security_patches-${SECPATCHVER}.tar.bz2"
-
-HOMEPAGE="http://www.linux-mips.org/"
-SLOT="${OKV}"
-PROVIDE="virtual/linux-sources"
-KEYWORDS="-*"
-IUSE=""
-
-
-pkg_setup() {
- # See if we're on a cobalt system (must use the cobalt-mips profile)
- if [ "${PROFILE_ARCH}" = "cobalt" ]; then
- echo -e ""
- einfo "Please keep in mind that the 2.6 kernel will NOT boot on Cobalt"
- einfo "systems that are still using the old Cobalt bootloader. In"
- einfo "order to boot a 2.6 kernel on Cobalt systems, you must be using"
- einfo "Peter Horton's new bootloader, which does not have the kernel"
- einfo "size limitation that the older bootloader has. If you want"
- einfo "to use the newer bootloader, make sure you have sys-boot/colo"
- einfo "installed and setup."
- echo -e ""
- fi
-}
-
-src_unpack() {
- unpack ${A}
- mv ${WORKDIR}/linux-${OKV} ${WORKDIR}/linux-${OKV}-${CVSDATE}
- cd ${S}
-
- # Update the vanilla sources with linux-mips CVS changes
- epatch ${WORKDIR}/mipscvs-${OKV}-${CVSDATE}.diff
-
- # Fix a compile glitch for SGI O2/IP32
- echo -e ""
- einfo ">>> Generic Patches"
- epatch ${FILESDIR}/mipscvs-2.6.7-maceisa_rtc_irq-fix.patch
-
- # In order to use arcboot on IP32, the kernel entry address needs to be
- # set to 0x98000000, not 0xa8000000.
- epatch ${FILESDIR}/mipscvs-2.6.x-ip32-kern_entry-arcboot.patch
-
- # Force detection of PS/2 mice on SGI Systems
- epatch ${FILESDIR}/misc-2.6-force_mouse_detection.patch
-
- # iluxa's minpatchset for SGI O2
- echo -e ""
- einfo ">>> Patching kernel with iluxa's minimal IP32 patchset ..."
- epatch ${WORKDIR}/ip32-iluxa-minpatchset-${IP32DIFFDATE}.diff
-
-
- # Security Fixes
- echo -e ""
- ebegin ">>> Applying Security Fixes"
- epatch ${WORKDIR}/security/security-2.6-proc_race.patch
- eend
-
-
- # Cobalt Patches
- if [ "${PROFILE_ARCH}" = "cobalt" ]; then
- echo -e ""
- einfo ">>> Patching kernel for Cobalt support ..."
- for x in ${WORKDIR}/cobalt-patches-26xx-${COBALTPATCHVER}/*.patch; do
- epatch ${x}
- done
- cp ${WORKDIR}/cobalt-patches-26xx-${COBALTPATCHVER}/cobalt-patches.txt ${S}
- cd ${WORKDIR}
- mv ${WORKDIR}/linux-${OKV}-${CVSDATE} ${WORKDIR}/linux-${OKV}-${CVSDATE}.cobalt
- S="${S}.cobalt"
- fi
-
- kernel_universal_unpack
-}