summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/atop')
-rw-r--r--sys-process/atop/ChangeLog15
-rw-r--r--sys-process/atop/Manifest11
-rw-r--r--sys-process/atop/atop-1.13.ebuild26
-rw-r--r--sys-process/atop/atop-1.14.ebuild9
-rw-r--r--sys-process/atop/files/digest-atop-1.141
5 files changed, 27 insertions, 35 deletions
diff --git a/sys-process/atop/ChangeLog b/sys-process/atop/ChangeLog
index 2562dd57c446..e619813d3e45 100644
--- a/sys-process/atop/ChangeLog
+++ b/sys-process/atop/ChangeLog
@@ -1,15 +1,6 @@
-# ChangeLog for sys-process/atop
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/ChangeLog,v 1.4 2005/06/14 23:01:10 vapier Exp $
-
- 14 Jun 2005; Mike Frysinger <vapier@gentoo.org> +files/atop.rc,
- atop-1.14.ebuild:
- Move init.d script off of mirrors and into $FILESDIR #96054.
-
-*atop-1.14 (07 May 2005)
-
- 07 May 2005; Mike Frysinger <vapier@gentoo.org> +atop-1.14.ebuild:
- Version bump #76202 by Jonathan Smith.
+# ChangeLog for sys-apps/atop
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/ChangeLog,v 1.1 2005/03/03 15:26:22 ciaranm Exp $
*atop-1.9 (03 Mar 2005)
diff --git a/sys-process/atop/Manifest b/sys-process/atop/Manifest
index 69d85f85b540..ba5ff78854b5 100644
--- a/sys-process/atop/Manifest
+++ b/sys-process/atop/Manifest
@@ -1,9 +1,6 @@
-MD5 a7863475f8ddf9c7201308c7cfc38842 ChangeLog 1329
-MD5 d3612abbc6260be66d61da2edf1aad9b atop-1.13.ebuild 877
-MD5 701d2375c48535ed551339c615c090f4 atop-1.9.ebuild 766
+MD5 eeb60f55975345de713e4e94c0c1e6a4 ChangeLog 857
+MD5 6d35307d60894bfab2aa30cacc682a5b atop-1.13.ebuild 871
+MD5 1c778088f971e4891c1e59e93f3ab68f atop-1.9.ebuild 763
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 adacc2c64bf5669a504909cb6083aa10 atop-1.14.ebuild 751
-MD5 7935c27e6af3265ca47b17c2cfabf937 files/digest-atop-1.14 61
-MD5 64d981f140d4e6136ab5e48b54cf3d2f files/digest-atop-1.13 122
MD5 c21353e3cfd66e9e2108b1da390e9fad files/digest-atop-1.9 120
-MD5 c4cea2eb117432cd1afff2b4ded1b10c files/atop.rc 611
+MD5 64d981f140d4e6136ab5e48b54cf3d2f files/digest-atop-1.13 122
diff --git a/sys-process/atop/atop-1.13.ebuild b/sys-process/atop/atop-1.13.ebuild
index 5413be52ef44..6b403075df2f 100644
--- a/sys-process/atop/atop-1.13.ebuild
+++ b/sys-process/atop/atop-1.13.ebuild
@@ -1,35 +1,35 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.13.ebuild,v 1.3 2005/05/07 06:26:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.13.ebuild,v 1.1 2005/03/03 15:26:22 ciaranm Exp $
+
ATOP_INIT_VERSION="1.9"
ATOP_INIT_SCRIPT=${PN}-${ATOP_INIT_VERSION}-initscript
DESCRIPTION="Resource-specific view of processes"
-HOMEPAGE="http://freshmeat.net/releases/112061/"
SRC_URI="ftp://ftp.atcomputing.nl/pub/tools/linux/${P}.tar.gz
- mirror://gentoo/${PN}-${ATOP_INIT_VERSION}-initscript"
-
+ mirror://gentoo/${PN}-${ATOP_INIT_VERSION}-initscript"
+HOMEPAGE="http://freshmeat.net/releases/112061/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
DEPEND="sys-process/acct"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
src_unpack() {
unpack ${A}
- cd "${S}"
- mv "${S}"/atop.init "${S}"/atop.init.old
- cp "${DISTDIR}/${ATOP_INIT_SCRIPT}" "${S}"/atop.init
- chmod a+rx atop.init
+ cd ${S}
+ mv ${S}/atop.init ${S}/atop.init.old
+ cp ${DISTDIR}/${ATOP_INIT_SCRIPT} ${S}/atop.init
}
src_compile() {
emake || die
}
-src_install() {
- make DESTDIR="${D}" INIPATH=/etc/init.d install || die
+src_install () {
+ make DESTDIR=${D} INIPATH=/etc/init.d install || die
+
+ # Install documentation.
dodoc README
}
diff --git a/sys-process/atop/atop-1.14.ebuild b/sys-process/atop/atop-1.14.ebuild
index 9f77e4b2daf8..8d858ae5f9fd 100644
--- a/sys-process/atop/atop-1.14.ebuild
+++ b/sys-process/atop/atop-1.14.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.14.ebuild,v 1.2 2005/06/14 23:01:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.14.ebuild,v 1.1 2005/05/07 06:34:44 vapier Exp $
+ATOP_INIT_VERSION="1.9"
+ATOP_INIT_SCRIPT=${PN}-${ATOP_INIT_VERSION}-initscript
DESCRIPTION="Resource-specific view of processes"
HOMEPAGE="http://www.atcomputing.nl/Tools/atop"
-SRC_URI="http://www.atconsultancy.nl/atop/packages/${P}.tar.gz"
+SRC_URI="http://www.atconsultancy.nl/atop/packages/${P}.tar.gz
+ mirror://gentoo/${PN}-${ATOP_INIT_VERSION}-initscript"
LICENSE="GPL-2"
SLOT="0"
@@ -18,7 +21,7 @@ src_unpack() {
cd "${S}"
sed -i -e "/^CFLAGS/s: -O : ${CFLAGS} :" Makefile
mv "${S}"/atop.init "${S}"/atop.init.old
- cp "${FILESDIR}"/atop.rc "${S}"/atop.init
+ cp "${DISTDIR}/${ATOP_INIT_SCRIPT}" "${S}"/atop.init
chmod a+rx atop.init
}
diff --git a/sys-process/atop/files/digest-atop-1.14 b/sys-process/atop/files/digest-atop-1.14
index e835cebb3c17..7f224e13e017 100644
--- a/sys-process/atop/files/digest-atop-1.14
+++ b/sys-process/atop/files/digest-atop-1.14
@@ -1 +1,2 @@
MD5 51ed85ea8d869568bd4038485c753756 atop-1.14.tar.gz 108748
+MD5 9e1db520318f831ff4f5006dc737eaa7 atop-1.9-initscript 521