summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-evdev')
-rw-r--r--x11-drivers/xf86-input-evdev/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-evdev/ChangeLog b/x11-drivers/xf86-input-evdev/ChangeLog
index f761d1b90fad..ca46c6356363 100644
--- a/x11-drivers/xf86-input-evdev/ChangeLog
+++ b/x11-drivers/xf86-input-evdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-evdev
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.88 2008/10/27 01:51:53 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.89 2008/12/04 18:07:49 cardoe Exp $
+
+*xf86-input-evdev-2.0.8 (04 Dec 2008)
+
+ 04 Dec 2008; Doug Goldstein <cardoe@gentoo.org>
+ +xf86-input-evdev-2.0.8.ebuild:
+ minor 64 bit fix in this version
*xf86-input-evdev-2.0.7 (27 Oct 2008)
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild
new file mode 100644
index 000000000000..d7a2ded681c9
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild,v 1.1 2008/12/04 18:07:49 cardoe Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="hal"
+RDEPEND=">=x11-base/xorg-server-1.4.0.90
+ hal? ( >=sys-apps/hal-0.5.10 )"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ pkg_info
+}
+
+pkg_info() {
+ if use hal; then
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+ fi
+}