summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/qwt')
-rw-r--r--x11-libs/qwt/ChangeLog6
-rw-r--r--x11-libs/qwt/files/qwt-6.1.1-pc-destdir.patch8
-rw-r--r--x11-libs/qwt/qwt-6.1.2.ebuild10
3 files changed, 17 insertions, 7 deletions
diff --git a/x11-libs/qwt/ChangeLog b/x11-libs/qwt/ChangeLog
index 6fc59d01f716..e349e4813e6c 100644
--- a/x11-libs/qwt/ChangeLog
+++ b/x11-libs/qwt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qwt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.134 2014/12/21 15:35:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.135 2014/12/24 09:46:26 jlec Exp $
+
+ 24 Dec 2014; Justin Lecher <jlec@gentoo.org> qwt-6.1.2.ebuild,
+ files/qwt-6.1.1-pc-destdir.patch:
+ Add opengl support; fix wrong lib location in pc file, #523490
*qwt-6.1.2 (21 Dec 2014)
diff --git a/x11-libs/qwt/files/qwt-6.1.1-pc-destdir.patch b/x11-libs/qwt/files/qwt-6.1.1-pc-destdir.patch
index 7b3dcef99299..f00ea604f5f4 100644
--- a/x11-libs/qwt/files/qwt-6.1.1-pc-destdir.patch
+++ b/x11-libs/qwt/files/qwt-6.1.1-pc-destdir.patch
@@ -1,10 +1,10 @@
- qwt-6.1.2/textengines/mathml/mathml.pro | 1 +
+ textengines/mathml/mathml.pro | 1 +
1 file changed, 1 insertion(+)
-diff --git a/qwt-6.1.2/textengines/mathml/mathml.pro b/qwt-6.1.2/textengines/mathml/mathml.pro
+diff --git a/textengines/mathml/mathml.pro b/textengines/mathml/mathml.pro
index 7032366..b1372f7 100644
---- a/qwt-6.1.2/textengines/mathml/mathml.pro
-+++ b/qwt-6.1.2/textengines/mathml/mathml.pro
+--- a/textengines/mathml/mathml.pro
++++ b/textengines/mathml/mathml.pro
@@ -63,6 +63,7 @@ contains(QWT_CONFIG, QwtPkgConfig) {
# QMAKE_PKGCONFIG_DESTDIR is buggy, in combination
diff --git a/x11-libs/qwt/qwt-6.1.2.ebuild b/x11-libs/qwt/qwt-6.1.2.ebuild
index 31fd9ec907dc..cc9a2c934d8e 100644
--- a/x11-libs/qwt/qwt-6.1.2.ebuild
+++ b/x11-libs/qwt/qwt-6.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-6.1.2.ebuild,v 1.1 2014/12/21 15:35:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-6.1.2.ebuild,v 1.2 2014/12/24 09:46:26 jlec Exp $
EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV/_/-}/${MY_P}.tar.bz2"
LICENSE="qwt mathml? ( LGPL-2.1 Nokia-Qt-LGPL-Exception-1.1 )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
SLOT="6"
-IUSE="doc examples mathml static-libs svg"
+IUSE="doc examples mathml opengl static-libs svg"
DEPEND="
!<x11-libs/qwt-5.2.3
@@ -23,6 +23,7 @@ DEPEND="
dev-qt/qtcore:4
dev-qt/qtgui:4
doc? ( !<media-libs/coin-3.1.3[doc] )
+ opengl? ( virtual/opengl )
svg? ( dev-qt/qtsvg:4 )"
RDEPEND="${DEPEND}"
@@ -48,6 +49,7 @@ src_prepare() {
EOF
use mathml && echo "QWT_CONFIG += QwtMathML" >> qwtconfig.pri
+ use opengl && echo "QWT_CONFIG += QwtOpenGL" >> qwtconfig.pri
use svg && echo "QWT_CONFIG += QwtSvg" >> qwtconfig.pri
cat > qwtbuild.pri <<-EOF
@@ -101,6 +103,10 @@ src_install () {
rm -f doc/man/*/{_,deprecated}* || die
multibuild_foreach_variant run_in_build_dir qt4-r2_src_install
+ sed \
+ -e "s: -L${WORKDIR}.* -lqwt6: -lqwt6:g" \
+ -i "${ED}"/usr/$(get_libdir)/pkgconfig/qwtmathml.pc || die
+
use doc && dohtml -r doc/html/*
if use examples; then