From 8c3cd13f0d76b9c54cbc50fcd5a5407c72b36f93 Mon Sep 17 00:00:00 2001
From: Diego Elio Pettenò <flameeyes@gentoo.org>
Date: Fri, 6 Jan 2006 23:37:59 +0000
Subject: Replace an userland check by $CHOST check; added comment with
 reasons. (Portage version: 2529-svn)

---
 sys-libs/com_err/ChangeLog           |  7 +++++--
 sys-libs/com_err/com_err-1.38.ebuild | 13 ++++++++-----
 sys-libs/ss/ChangeLog                |  7 +++++--
 sys-libs/ss/ss-1.38.ebuild           | 13 ++++++++-----
 4 files changed, 26 insertions(+), 14 deletions(-)

diff --git a/sys-libs/com_err/ChangeLog b/sys-libs/com_err/ChangeLog
index 25420cc5204f..09c88609e287 100644
--- a/sys-libs/com_err/ChangeLog
+++ b/sys-libs/com_err/ChangeLog
@@ -1,6 +1,9 @@
 # ChangeLog for sys-libs/com_err
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/ChangeLog,v 1.21 2005/11/10 21:22:09 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/ChangeLog,v 1.22 2006/01/06 23:34:22 flameeyes Exp $
+
+  06 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> com_err-1.38.ebuild:
+  Replace an userland check by $CHOST check; added comment with reasons.
 
   10 Nov 2005; Diego Pettenò <flameeyes@gentoo.org> com_err-1.38.ebuild:
   Move exporting of vars in src_compile() and src_install() to work around
diff --git a/sys-libs/com_err/com_err-1.38.ebuild b/sys-libs/com_err/com_err-1.38.ebuild
index 93125668a5e0..87e1b2ed5adb 100644
--- a/sys-libs/com_err/com_err-1.38.ebuild
+++ b/sys-libs/com_err/com_err-1.38.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.38.ebuild,v 1.16 2005/11/10 21:22:09 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.38.ebuild,v 1.17 2006/01/06 23:34:22 flameeyes Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -29,11 +29,14 @@ src_compile() {
 	export CC=$(tc-getCC)
 	export STRIP=/bin/true
 
+	# We want to use the "bsd" libraries while building on Darwin, but while
+	# building on other Gentoo/*BSD we prefer elf-naming scheme.
 	local libtype
-	case ${USERLAND} in
-		Darwin) libtype=bsd;;
-		*)      libtype=elf;;
+	case ${CHOST} in
+		*-darwin*) libtype=bsd;;
+		*)         libtype=elf;;
 	esac
+	
 	mkdir -p lib/{blkid,e2p,et,ext2fs,ss,uuid}/{checker,elfshared,pic,profiled} #102412
 	econf \
 		--enable-${libtype}-shlibs \
diff --git a/sys-libs/ss/ChangeLog b/sys-libs/ss/ChangeLog
index 91224e819889..43257ad50e44 100644
--- a/sys-libs/ss/ChangeLog
+++ b/sys-libs/ss/ChangeLog
@@ -1,6 +1,9 @@
 # ChangeLog for sys-libs/ss
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ChangeLog,v 1.20 2005/11/10 21:26:46 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ChangeLog,v 1.21 2006/01/06 23:37:59 flameeyes Exp $
+
+  06 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> ss-1.38.ebuild:
+  Replace an userland check by $CHOST check; added comment with reasons.
 
   10 Nov 2005; Diego Pettenò <flameeyes@gentoo.org> ss-1.38.ebuild:
   Move exporting of vars in src_compile() and src_install() to work around
diff --git a/sys-libs/ss/ss-1.38.ebuild b/sys-libs/ss/ss-1.38.ebuild
index f6ffeb5daf6b..b4ce6e54184a 100644
--- a/sys-libs/ss/ss-1.38.ebuild
+++ b/sys-libs/ss/ss-1.38.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.38.ebuild,v 1.16 2005/11/10 21:26:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.38.ebuild,v 1.17 2006/01/06 23:37:59 flameeyes Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -31,11 +31,14 @@ src_compile() {
 	export CC=$(tc-getCC)
 	export STRIP=/bin/true
 
+	# We want to use the "bsd" libraries while building on Darwin, but while
+	# building on other Gentoo/*BSD we prefer elf-naming scheme.
 	local libtype
-	case ${USERLAND} in
-		Darwin) libtype=bsd;;
-		*)      libtype=elf;;
+	case ${CHOST} in
+		*-darwin*) libtype=bsd;;
+		*)         libtype=elf;;
 	esac
+	
 	mkdir -p lib/{blkid,e2p,et,ext2fs,ss,uuid}/{checker,elfshared,pic,profiled} #102412
 	econf \
 		--enable-${libtype}-shlibs \
-- 
cgit v1.2.3-65-gdbad