From fbeb6513c49ab4b5f367c34153e9ad57b6252671 Mon Sep 17 00:00:00 2001
From: Ben de Groot <yngwin@gentoo.org>
Date: Sun, 29 Mar 2015 11:22:52 +0000
Subject: Version bump, which fixes security bugs #538152 and #540626. Bump
 EAPI. Rename extra-tools useflag to extras (bug #411643). Remove old.

(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
---
 app-arch/cabextract/ChangeLog             |  9 +++++++-
 app-arch/cabextract/cabextract-1.3.ebuild | 28 -----------------------
 app-arch/cabextract/cabextract-1.4.ebuild | 12 +++++-----
 app-arch/cabextract/cabextract-1.6.ebuild | 38 +++++++++++++++++++++++++++++++
 app-arch/cabextract/metadata.xml          | 13 ++++++-----
 5 files changed, 59 insertions(+), 41 deletions(-)
 delete mode 100644 app-arch/cabextract/cabextract-1.3.ebuild
 create mode 100644 app-arch/cabextract/cabextract-1.6.ebuild

diff --git a/app-arch/cabextract/ChangeLog b/app-arch/cabextract/ChangeLog
index e78b58616f3d..5395b6c6379b 100644
--- a/app-arch/cabextract/ChangeLog
+++ b/app-arch/cabextract/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for app-arch/cabextract
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/ChangeLog,v 1.76 2015/03/03 05:39:32 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/ChangeLog,v 1.77 2015/03/29 11:22:52 yngwin Exp $
+
+*cabextract-1.6 (29 Mar 2015)
+
+  29 Mar 2015; Ben de Groot <yngwin@gentoo.org> +cabextract-1.6.ebuild,
+  -cabextract-1.3.ebuild, cabextract-1.4.ebuild, metadata.xml:
+  Version bump, which fixes security bugs #538152 and #540626. Bump EAPI. Rename
+  extra-tools useflag to extras (bug #411643). Remove old.
 
   02 Mar 2015; Yixun Lan <dlan@gentoo.org> cabextract-1.4.ebuild:
   add arm64 support, tested on A53 board
diff --git a/app-arch/cabextract/cabextract-1.3.ebuild b/app-arch/cabextract/cabextract-1.3.ebuild
deleted file mode 100644
index 760243b6d379..000000000000
--- a/app-arch/cabextract/cabextract-1.3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.3.ebuild,v 1.7 2010/09/28 20:33:31 vapier Exp $
-
-DESCRIPTION="Extracts files from Microsoft .cab files"
-HOMEPAGE="http://www.cabextract.org.uk/"
-SRC_URI="http://www.cabextract.org.uk/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="extra-tools"
-
-RDEPEND="extra-tools? ( dev-lang/perl )"
-
-# the code attempts to set up a fnmatch replacement, but then fails to code
-# it properly leading to undefined references to rpl_fnmatch().  This may be
-# removed in the future if building still works by setting "yes" to "no".
-export ac_cv_func_fnmatch_works=yes
-
-src_install() {
-	emake DESTDIR="${D}" install || die "emake failed"
-	dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic
-	dohtml doc/wince_cab_format.html
-	if use extra-tools; then
-		dobin src/{wince_info,wince_rename,cabinfo} || die
-	fi
-}
diff --git a/app-arch/cabextract/cabextract-1.4.ebuild b/app-arch/cabextract/cabextract-1.4.ebuild
index 2d88aa85bc94..a530beccf419 100644
--- a/app-arch/cabextract/cabextract-1.4.ebuild
+++ b/app-arch/cabextract/cabextract-1.4.ebuild
@@ -1,21 +1,21 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.4.ebuild,v 1.12 2015/03/03 05:39:32 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.4.ebuild,v 1.13 2015/03/29 11:22:52 yngwin Exp $
 
-EAPI="4"
+EAPI=4
 
 inherit toolchain-funcs
 
-DESCRIPTION="Extracts files from Microsoft .cab files"
+DESCRIPTION="Extracts files from Microsoft cabinet archive files"
 HOMEPAGE="http://www.cabextract.org.uk/"
 SRC_URI="http://www.cabextract.org.uk/${P}.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="extra-tools"
+IUSE="extras"
 
-RDEPEND="extra-tools? ( dev-lang/perl )"
+RDEPEND="extras? ( dev-lang/perl )"
 
 # the code attempts to set up a fnmatch replacement, but then fails to code
 # it properly leading to undefined references to rpl_fnmatch().  This may be
@@ -30,7 +30,7 @@ src_install() {
 	emake DESTDIR="${D}" install
 	dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic
 	dohtml doc/wince_cab_format.html
-	if use extra-tools; then
+	if use extras; then
 		dobin src/{wince_info,wince_rename,cabinfo}
 	fi
 }
diff --git a/app-arch/cabextract/cabextract-1.6.ebuild b/app-arch/cabextract/cabextract-1.6.ebuild
new file mode 100644
index 000000000000..395fb8478393
--- /dev/null
+++ b/app-arch/cabextract/cabextract-1.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.6.ebuild,v 1.1 2015/03/29 11:22:52 yngwin Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Extracts files from Microsoft cabinet archive files"
+HOMEPAGE="http://www.cabextract.org.uk/"
+SRC_URI="http://www.cabextract.org.uk/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390
+	~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux
+	~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris
+	~x86-solaris"
+IUSE="extras"
+
+RDEPEND="extras? ( dev-lang/perl )"
+
+# the code attempts to set up a fnmatch replacement, but then fails to code
+# it properly leading to undefined references to rpl_fnmatch().  This may be
+# removed in the future if building still works by setting "yes" to "no".
+export ac_cv_func_fnmatch_works=yes
+
+src_compile() {
+	emake AR="$(tc-getAR)"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install
+	dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic
+	dohtml doc/wince_cab_format.html
+	if use extras; then
+		dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
+	fi
+}
diff --git a/app-arch/cabextract/metadata.xml b/app-arch/cabextract/metadata.xml
index 1acfbec9e034..78a6f5f7ea4a 100644
--- a/app-arch/cabextract/metadata.xml
+++ b/app-arch/cabextract/metadata.xml
@@ -1,10 +1,11 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<herd>fonts</herd>
-<use>
-	<flag name="extra-tools">Install experimental tools: wince_info and
-	wince_rename for examining and processing Windows CE installation cabinet
-	header files; cabinfo for examining the structure of a cab file.</flag>
-</use>
+  <herd>fonts</herd>
+  <use>
+    <flag name="extras">Install experimental extra tools: wince_info and
+      wince_rename for examining and processing Windows CE installation cabinet
+      header files; cabinfo for examining the structure of a cab file.
+    </flag>
+  </use>
 </pkgmetadata>
-- 
cgit v1.2.3-65-gdbad