From a0570e3aa19558627c0fd79ab4e9f6f2124ec6fa Mon Sep 17 00:00:00 2001
From: Masatomo Nakano <nakano@gentoo.org>
Date: Tue, 20 Mar 2007 13:02:55 +0000
Subject: Version bump. (Portage version: 2.1.2.2)

---
 app-admin/puppet/ChangeLog                  |  7 +++-
 app-admin/puppet/files/digest-puppet-0.22.2 |  3 ++
 app-admin/puppet/puppet-0.22.2.ebuild       | 63 +++++++++++++++++++++++++++++
 3 files changed, 72 insertions(+), 1 deletion(-)
 create mode 100644 app-admin/puppet/files/digest-puppet-0.22.2
 create mode 100644 app-admin/puppet/puppet-0.22.2.ebuild

(limited to 'app-admin/puppet')

diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index bde9bc58fbc7..ec6c38512e7f 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for app-admin/puppet
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.1 2007/03/17 17:44:12 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.2 2007/03/20 13:02:55 nakano Exp $
+
+*puppet-0.22.2 (20 Mar 2007)
+
+  20 Mar 2007; Masatomo Nakano <nakano@gentoo.org> +puppet-0.22.2.ebuild:
+  Version bump.
 
 *puppet-0.22.1 (17 Mar 2007)
 
diff --git a/app-admin/puppet/files/digest-puppet-0.22.2 b/app-admin/puppet/files/digest-puppet-0.22.2
new file mode 100644
index 000000000000..6908726ffa27
--- /dev/null
+++ b/app-admin/puppet/files/digest-puppet-0.22.2
@@ -0,0 +1,3 @@
+MD5 470581376bb1b6f7aaed666dc144bd12 puppet-0.22.2.tgz 627039
+RMD160 199d058b9622bc964a720c4d939e1c8376b5d140 puppet-0.22.2.tgz 627039
+SHA256 3361c5779cecb52673953e58e19e1c1e13a0ec386a4980469792dd3de9417fca puppet-0.22.2.tgz 627039
diff --git a/app-admin/puppet/puppet-0.22.2.ebuild b/app-admin/puppet/puppet-0.22.2.ebuild
new file mode 100644
index 000000000000..a3e48c77880b
--- /dev/null
+++ b/app-admin/puppet/puppet-0.22.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.22.2.ebuild,v 1.1 2007/03/20 13:02:55 nakano Exp $
+
+inherit eutils ruby
+
+DESCRIPTION="A system automation and configuration management software"
+LICENSE="GPL-2"
+HOMEPAGE="http://reductivelabs.com/projects/puppet/index.html"
+SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
+RDEPEND=">=dev-ruby/facter-1.3.5 >=app-portage/eix-0.7.9"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+
+USE_RUBY="ruby18"
+
+pkg_setup() {
+	built_with_use virtual/ruby ipv6 || \
+		die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
+
+	enewgroup puppet || die "Problem creating group puppet"
+	enewuser puppet -1 -1 /var/lib/puppet puppet || die "Problem creating user puppet"
+}
+
+src_compile() {
+	DESTDIR=${D} ruby_econf || die
+	DESTDIR=${D} ruby_emake "$@" || die
+}
+
+src_install() {
+	DESTDIR=${D} ruby_einstall "$@" || die
+	DESTDIR=${D} erubydoc
+
+	# Installation of init scripts and configuration
+	doinitd ${S}/conf/gentoo/init.d/puppetmaster
+	doconfd ${S}/conf/gentoo/conf.d/puppetmaster
+	doinitd ${S}/conf/gentoo/init.d/puppet
+	doconfd ${S}/conf/gentoo/conf.d/puppet
+
+
+	# Initial configuration files
+	dodir /etc/puppet/manifests
+	insinto /etc/puppet
+	doins ${S}/conf/gentoo/puppet/*
+
+	# Location of log and data files
+	dodir /var/log/puppet
+	dodir /var/lib/puppet
+	keepdir /var/run/puppet
+}
+
+pkg_postinst() {
+	ewarn "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could cause puppet to hang"
+	ewarn "while installing packages."
+	ewarn
+	ewarn "Puppet uses eix to get information about currently installed	packages, so please keep the eix"
+	ewarn "metadata cache updated so puppet is able to properly handle package installations."
+	ewarn
+	ewarn "Currently puppet only supports adding and removing services to the default runlevel, if you"
+	ewarn "want to add/remove a service from another runlevel you may do so using symlinking."
+}
-- 
cgit v1.2.3-65-gdbad