From 16f141449dcaf23f02704113a137bfe3acc44b8f Mon Sep 17 00:00:00 2001
From: Yixun Lan <dlan@gentoo.org>
Date: Mon, 18 Aug 2014 06:04:03 +0000
Subject: correct SRC_URI, fix bug 518820, 519220

(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
---
 app-i18n/ibus/ChangeLog            |   8 +-
 app-i18n/ibus/ibus-1.5.8-r1.ebuild | 175 ++++++++++++++++++++++++++++++++++++
 app-i18n/ibus/ibus-1.5.8.ebuild    | 176 -------------------------------------
 3 files changed, 182 insertions(+), 177 deletions(-)
 create mode 100644 app-i18n/ibus/ibus-1.5.8-r1.ebuild
 delete mode 100644 app-i18n/ibus/ibus-1.5.8.ebuild

(limited to 'app-i18n/ibus')

diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 572c8aee598d..d7af72009462 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for app-i18n/ibus
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.148 2014/08/04 07:22:49 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.149 2014/08/18 06:04:03 dlan Exp $
+
+*ibus-1.5.8-r1 (18 Aug 2014)
+
+  18 Aug 2014; Yixun Lan <dlan@gentoo.org> -ibus-1.5.8.ebuild,
+  +ibus-1.5.8-r1.ebuild:
+  correct SRC_URI, fix bug 518820, 519220
 
   04 Aug 2014; Yixun Lan <dlan@gentoo.org> ibus-1.5.8.ebuild:
   bug 518746, add dev-util/gtk-doc depend, since upstream don't do release
diff --git a/app-i18n/ibus/ibus-1.5.8-r1.ebuild b/app-i18n/ibus/ibus-1.5.8-r1.ebuild
new file mode 100644
index 000000000000..ddc84ab4c081
--- /dev/null
+++ b/app-i18n/ibus/ibus-1.5.8-r1.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.5.8-r1.ebuild,v 1.1 2014/08/18 06:04:03 dlan Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+# Vapigen is needed for the vala binding
+# Valac is needed when building from git for the engine
+
+inherit bash-completion-r1 eutils gnome2-utils multilib python-single-r1 readme.gentoo vala virtualx
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="https://github.com/ibus/ibus/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="deprecated gconf gtk +gtk3 +introspection nls +python test vala wayland +X"
+REQUIRED_USE="|| ( gtk gtk3 X )
+	deprecated? ( python )
+	python? (
+		${PYTHON_REQUIRED_USE}
+		|| ( deprecated ( gtk3 introspection ) ) )" #342903
+
+COMMON_DEPEND="
+	>=dev-libs/glib-2.26:2
+	gnome-base/librsvg:2
+	sys-apps/dbus[X?]
+	app-text/iso-codes
+	>=gnome-base/dconf-0.13.4
+	x11-libs/libnotify
+
+	gconf? ( >=gnome-base/gconf-2.12:2 )
+	gtk? ( x11-libs/gtk+:2 )
+	gtk3? ( x11-libs/gtk+:3 )
+	python? ( ${PYTHON_DEPS} )
+	X? (
+		x11-libs/libX11
+		x11-libs/gtk+:2 )
+	introspection? ( >=dev-libs/gobject-introspection-0.6.8 )
+	nls? ( virtual/libintl )
+	wayland? ( dev-libs/wayland )"
+RDEPEND="${COMMON_DEPEND}
+	x11-apps/setxkbmap
+	python? (
+		dev-python/pyxdg
+		deprecated? (
+			>=dev-python/dbus-python-0.83
+			dev-python/pygobject:2
+			dev-python/pygtk:2 )
+		gtk3? (
+			dev-python/pygobject:3
+			x11-libs/gdk-pixbuf:2[introspection]
+			x11-libs/pango[introspection]
+			x11-libs/gtk+:3[introspection] )
+	)"
+DEPEND="${COMMON_DEPEND}
+	>=dev-lang/perl-5.8.1
+	dev-util/gtk-doc-am
+	dev-util/intltool
+	virtual/pkgconfig
+	nls? ( >=sys-devel/gettext-0.16.1 )
+	vala? ( $(vala_depend) )
+	gnome-base/gconf"
+
+# stress test in bus/ fails
+# IBUS-CRITICAL **: bus_test_client_init: assertion `ibus_bus_is_connected (_bus)' failed
+RESTRICT="test"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="To use ibus, you should:
+1. Get input engines from sunrise overlay.
+Run \"emerge -s ibus-\" in your favorite terminal
+for a list of packages we already have.
+
+2. Setup ibus:
+$ ibus-setup
+
+3. Set the following in your user startup scripts
+such as .xinitrc, .xsession or .xprofile:
+
+export XMODIFIERS=\"@im=ibus\"
+export GTK_IM_MODULE=\"ibus\"
+export QT_IM_MODULE=\"xim\"
+ibus-daemon -d -x
+"
+
+pkg_setup() {
+	use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+	# We run "dconf update" in pkg_postinst/postrm to avoid sandbox violations
+	sed -e 's/dconf update/$(NULL)/' \
+		-i data/dconf/Makefile.{am,in} || die
+	use vala && vala_src_prepare
+}
+
+src_configure() {
+	local python_conf
+	if use python; then
+		python_conf="PYTHON=${PYTHON}
+			$(use_enable deprecated python-library)
+			$(use_enable gtk3 setup)"
+	else
+		python_conf="--disable-python-library --disable-setup"
+	fi
+	econf \
+		--enable-dconf \
+		$(use_enable introspection) \
+		$(use_enable gconf) \
+		$(use_enable gtk gtk2) \
+		$(use_enable gtk xim) \
+		$(use_enable gtk3) \
+		$(use_enable gtk3 ui) \
+		$(use_enable nls) \
+		$(use_enable test tests) \
+		$(use_enable X xim) \
+		$(use_enable vala) \
+		$(use_enable wayland) \
+		${python_conf}
+}
+
+src_test() {
+	unset DBUS_SESSION_BUS_ADDRESS
+	Xemake check || die
+}
+
+src_install() {
+	default
+
+	prune_libtool_files --all
+
+	mv "${ED}"/usr/share/bash-completion/completions/ibus.bash "${T}"
+	rm -rf "${ED}"/usr/share/bash-completion || die
+	newbashcomp "${T}"/ibus.bash ${PN}
+	insinto /etc/X11/xinit/xinput.d
+	newins xinput-ibus ibus.conf
+
+	keepdir /usr/share/ibus/{engine,icons} #289547
+
+	use deprecated && python_optimize
+	use python && use gtk3 && python_optimize
+
+	readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+	use gconf && gnome2_gconf_savelist
+	gnome2_schemas_savelist
+	gnome2_icon_savelist
+}
+
+pkg_postinst() {
+	use gconf && gnome2_gconf_install
+	use gtk && gnome2_query_immodules_gtk2
+	use gtk3 && gnome2_query_immodules_gtk3
+	gnome2_schemas_update
+	gnome2_icon_cache_update
+	readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+	use gtk && gnome2_query_immodules_gtk2
+	use gtk3 && gnome2_query_immodules_gtk3
+	use gconf && gnome2_schemas_update
+	gnome2_schemas_savelist
+	gnome2_icon_cache_update
+}
diff --git a/app-i18n/ibus/ibus-1.5.8.ebuild b/app-i18n/ibus/ibus-1.5.8.ebuild
deleted file mode 100644
index 6c1d0eb7014d..000000000000
--- a/app-i18n/ibus/ibus-1.5.8.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.5.8.ebuild,v 1.2 2014/08/04 07:22:49 dlan Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-VALA_MIN_API_VERSION="0.18"
-VALA_USE_DEPEND="vapigen"
-# Vapigen is needed for the vala binding
-# Valac is needed when building from git for the engine
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils bash-completion-r1 eutils gnome2-utils multilib python-single-r1 readme.gentoo vala virtualx
-
-DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
-HOMEPAGE="http://code.google.com/p/ibus/"
-SRC_URI="https://github.com/ibus/ibus/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="deprecated gconf gtk +gtk3 +introspection nls +python test +vala wayland +X"
-REQUIRED_USE="|| ( gtk gtk3 X )
-	deprecated? ( python )
-	python? (
-		${PYTHON_REQUIRED_USE}
-		|| ( deprecated ( gtk3 introspection ) ) )" #342903
-
-COMMON_DEPEND="
-	>=dev-libs/glib-2.26:2
-	gnome-base/librsvg:2
-	sys-apps/dbus[X?]
-	app-text/iso-codes
-	>=gnome-base/dconf-0.13.4
-	x11-libs/libnotify
-
-	gconf? ( >=gnome-base/gconf-2.12:2 )
-	gtk? ( x11-libs/gtk+:2 )
-	gtk3? ( x11-libs/gtk+:3 )
-	python? ( ${PYTHON_DEPS} )
-	X? (
-		x11-libs/libX11
-		x11-libs/gtk+:2 )
-	introspection? ( >=dev-libs/gobject-introspection-0.6.8 )
-	nls? ( virtual/libintl )
-	wayland? ( dev-libs/wayland )"
-RDEPEND="${COMMON_DEPEND}
-	x11-apps/setxkbmap
-	python? (
-		dev-python/pyxdg
-		deprecated? (
-			>=dev-python/dbus-python-0.83
-			dev-python/pygobject:2
-			dev-python/pygtk:2 )
-		gtk3? (
-			dev-python/pygobject:3
-			x11-libs/gdk-pixbuf:2[introspection]
-			x11-libs/pango[introspection]
-			x11-libs/gtk+:3[introspection] )
-	)"
-DEPEND="${COMMON_DEPEND}
-	>=dev-lang/perl-5.8.1
-	dev-util/gtk-doc
-	dev-util/gtk-doc-am
-	dev-util/intltool
-	virtual/pkgconfig
-	nls? ( >=sys-devel/gettext-0.16.1 )
-	vala? ( $(vala_depend) )
-	gnome-base/gconf"
-
-# stress test in bus/ fails
-# IBUS-CRITICAL **: bus_test_client_init: assertion `ibus_bus_is_connected (_bus)' failed
-RESTRICT="test"
-
-DOCS="AUTHORS NEWS README"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="To use ibus, you should:
-1. Get input engines from sunrise overlay.
-Run \"emerge -s ibus-\" in your favorite terminal
-for a list of packages we already have.
-
-2. Setup ibus:
-$ ibus-setup
-
-3. Set the following in your user startup scripts
-such as .xinitrc, .xsession or .xprofile:
-
-export XMODIFIERS=\"@im=ibus\"
-export GTK_IM_MODULE=\"ibus\"
-export QT_IM_MODULE=\"xim\"
-ibus-daemon -d -x
-"
-
-pkg_setup() {
-	use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
-	autotools-utils_src_prepare
-	use vala && vala_src_prepare
-}
-
-src_configure() {
-	local python_conf
-	if use python; then
-		python_conf="PYTHON=${PYTHON}
-			$(use_enable deprecated python-library)
-			$(use_enable gtk3 setup)"
-	else
-		python_conf="--disable-python-library --disable-setup"
-	fi
-	econf \
-		--enable-dconf \
-		$(use_enable introspection) \
-		$(use_enable gconf) \
-		$(use_enable gtk gtk2) \
-		$(use_enable gtk xim) \
-		$(use_enable gtk3) \
-		$(use_enable gtk3 ui) \
-		$(use_enable nls) \
-		$(use_enable test tests) \
-		$(use_enable X xim) \
-		$(use_enable vala) \
-		$(use_enable wayland) \
-		${python_conf}
-}
-
-src_test() {
-	unset DBUS_SESSION_BUS_ADDRESS
-	Xemake check || die
-}
-
-src_install() {
-	default
-
-	prune_libtool_files --all
-
-	mv "${ED}"/usr/share/bash-completion/completions/ibus.bash "${T}"
-	rm -rf "${ED}"/usr/share/bash-completion || die
-	newbashcomp "${T}"/ibus.bash ${PN}
-	insinto /etc/X11/xinit/xinput.d
-	newins xinput-ibus ibus.conf
-
-	keepdir /usr/share/ibus/{engine,icons} #289547
-
-	use deprecated && python_optimize
-	use python && use gtk3 && python_optimize
-
-	readme.gentoo_create_doc
-}
-
-pkg_preinst() {
-	use gconf && gnome2_gconf_savelist
-	gnome2_schemas_savelist
-	gnome2_icon_savelist
-}
-
-pkg_postinst() {
-	use gconf && gnome2_gconf_install
-	use gtk && gnome2_query_immodules_gtk2
-	use gtk3 && gnome2_query_immodules_gtk3
-	gnome2_schemas_update
-	gnome2_icon_cache_update
-	readme.gentoo_print_elog
-}
-
-pkg_postrm() {
-	use gtk && gnome2_query_immodules_gtk2
-	use gtk3 && gnome2_query_immodules_gtk3
-	use gconf && gnome2_schemas_update
-	gnome2_schemas_savelist
-	gnome2_icon_cache_update
-}
-- 
cgit v1.2.3-65-gdbad