From bc6cf047aa7406c14ce557f75bdc44efbd92bc27 Mon Sep 17 00:00:00 2001
From: Matthias Schwarzott <zzam@gentoo.org>
Date: Sun, 12 Oct 2008 19:55:53 +0000
Subject: Version bumped. This adds Kernel 2.6.27 compatibility. Added driver
 options irlink, commandir, ite8709 and samsung, Bug #221727. Removed
 portaudio patch. Shorten description of lirc-0.8.0-r8. (Portage version:
 2.2_rc12/cvs/Linux 2.6.25-tuxonice-r6 i686)

---
 app-misc/lirc/ChangeLog                            |  11 +-
 app-misc/lirc/files/lirc-0.8.4-imon-pad2keys.patch | 291 ++++++++++++++++++
 app-misc/lirc/lirc-0.8.0-r8.ebuild                 |   7 +-
 app-misc/lirc/lirc-0.8.4.ebuild                    | 324 +++++++++++++++++++++
 4 files changed, 628 insertions(+), 5 deletions(-)
 create mode 100644 app-misc/lirc/files/lirc-0.8.4-imon-pad2keys.patch
 create mode 100644 app-misc/lirc/lirc-0.8.4.ebuild

(limited to 'app-misc')

diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index b989f549e16b..324618a88884 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,6 +1,15 @@
 # ChangeLog for app-misc/lirc
 # Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.188 2008/10/12 19:18:59 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.189 2008/10/12 19:55:53 zzam Exp $
+
+*lirc-0.8.4 (12 Oct 2008)
+
+  12 Oct 2008; Matthias Schwarzott <zzam@gentoo.org>
+  +files/lirc-0.8.4-imon-pad2keys.patch, lirc-0.8.0-r8.ebuild,
+  +lirc-0.8.4.ebuild:
+  Version bumped. This adds Kernel 2.6.27 compatibility. Added driver
+  options irlink, commandir, ite8709 and samsung, Bug #221727. Removed
+  portaudio patch. Shorten description of lirc-0.8.0-r8.
 
   12 Oct 2008; Matthias Schwarzott <zzam@gentoo.org> files/lircd.conf.2:
   Fix config example for devinput, Bug #235107
diff --git a/app-misc/lirc/files/lirc-0.8.4-imon-pad2keys.patch b/app-misc/lirc/files/lirc-0.8.4-imon-pad2keys.patch
new file mode 100644
index 000000000000..578489db446f
--- /dev/null
+++ b/app-misc/lirc/files/lirc-0.8.4-imon-pad2keys.patch
@@ -0,0 +1,291 @@
+diff -ruN lirc-0.8.3pre3-orig/drivers/lirc_imon/lirc_imon.c lirc-0.8.3pre3/drivers/lirc_imon/lirc_imon.c
+--- lirc-0.8.3pre3-orig/drivers/lirc_imon/lirc_imon.c	2008-04-28 22:15:54.281654857 +0200
++++ lirc-0.8.3pre3/drivers/lirc_imon/lirc_imon.c	2008-04-28 22:16:51.381649620 +0200
+@@ -73,9 +73,9 @@
+ 
+ 
+ #define MOD_AUTHOR	"Venky Raju <dev@venky.ws>"
+-#define MOD_DESC	"Driver for Soundgraph iMON MultiMedia IR/VFD"
++#define MOD_DESC	"Driver for Soundgraph iMON MultiMedia IR/VFD w/imon pad2keys patch"
+ #define MOD_NAME	"lirc_imon"
+-#define MOD_VERSION	"0.3"
++#define MOD_VERSION	"0.3p2k"
+ 
+ #define VFD_MINOR_BASE	144	/* Same as LCD */
+ #define DEVFS_MODE	(S_IFCHR | S_IRUSR | S_IWUSR | \
+@@ -91,6 +91,7 @@
+ #define	TRUE		1
+ #define FALSE		0
+ 
++#define CURSOR_LIMIT    16
+ 
+ /* ------------------------------------------------------------
+  *		     P R O T O T Y P E S
+@@ -177,6 +178,10 @@
+ 		atomic_t busy;			/* write in progress */
+ 		int status;			/* status of tx completion */
+ 	} tx;
++        
++        int key_x;
++        int key_y;
++        int last_count;                      /* number of times pressed   */
+ };
+ 
+ #define LOCK_CONTEXT	down(&context->sem)
+@@ -248,6 +253,9 @@
+ static int is_lcd; /* If LIRC_IMON_LCD not defined, default to non-LCD */
+ #endif
+ 
++/* pad2keys module parameter. pad2keys patch active? */
++static int pad2keys_active = 0;
++
+ #if !defined(KERNEL_2_5)
+ 
+ #define MAX_DEVICES	4	/* In case there's more than one iMON device */
+@@ -271,6 +279,7 @@
+ 
+ MODULE_AUTHOR(MOD_AUTHOR);
+ MODULE_DESCRIPTION(MOD_DESC);
++MODULE_VERSION(MOD_VERSION);    /* MBr: was missing */
+ MODULE_LICENSE("GPL");
+ MODULE_DEVICE_TABLE(usb, imon_usb_id_table);
+ 
+@@ -287,6 +296,9 @@
+ 		 "1=yes (default:no)");
+ #endif
+ 
++module_param (pad2keys_active, int, 0);
++MODULE_PARM_DESC (pad2keys_active, "pad2keys patch active: 0=no, 1=yes (default: no)");
++ 
+ static inline void delete_context(struct imon_context *context)
+ {
+ 	if (context->vfd_supported)
+@@ -766,6 +778,11 @@
+ 	context->rx.initial_space = 1;
+ 	context->rx.prev_bit = 0;
+ 
++        /* init pad context for pad2keys */
++        context ->key_x = 0;
++        context ->key_y = 0;
++        context ->last_count = 0;
++ 
+ 	usb_fill_int_urb(context->rx_urb, context->dev,
+ 		usb_rcvintpipe(context->dev,
+ 				context->rx_endpoint->bEndpointAddress),
+@@ -915,6 +932,94 @@
+ 
+ 	if (context->ir_onboard_decode) {
+ 		/* The signals have been decoded onboard the iMON controller */
++                
++                if (pad2keys_active)
++                {
++                   /* imon pad2keys patch
++                    *
++                    * make PAD and mouse buttons available for use with VDR,
++                    * based on pad-mouse-emu patch from venky's forum
++                    *
++                    * last change: M.Brakemeier 2007-10-14
++                    *
++                    * generated PAD key codes:
++                    * Mouse_N                  0x690281B7
++                    * Mouse_S                  0x688291B7
++                    * Mouse_W                  0x6A8281B7
++                    * Mouse_E                  0x688A81B7
++                    *
++                    * mouse buttons (non-synthetic):
++                    * MouseRightClick          0x688481B7
++                    * MouseLeftClick           0x688301B7
++                    */
++                    if((buf[0] & 0x40) &&
++                        !(buf[1] & 0x01 || buf[1] >> 2 & 0x01))
++                    {
++                        int rel_x = (buf[1] & 0x08) | (buf[1] & 0x10) >> 2 | (buf[1] & 0x20) >> 4 | (buf[1] & 0x40) >> 6;
++                        int rel_y = (buf[2] & 0x08) | (buf[2] & 0x10) >> 2 | (buf[2] & 0x20) >> 4 | (buf[2] & 0x40) >> 6;
++        
++                        if(buf[0] & 0x02)
++                            rel_x |= ~0x10+1;
++                        if(buf[0] & 0x01)
++                            rel_y |= ~0x10+1;
++        
++                        /* keyboard direction key emulation */
++                        if( context->last_count > 32 )
++                        {  /* Hopefully eliminate drift*/
++                            context->last_count=0;
++                            context->key_y=0;
++                            context->key_x=0;
++                        }
++                        context->last_count++;
++        
++                        /* limit decoded events */
++                        if(abs(context->key_x) > CURSOR_LIMIT || abs(context->key_y) > CURSOR_LIMIT )
++                        {
++                            if(abs(context->key_y ) > abs(context->key_x))
++                            { /* mouse s/n */
++                                if(context->key_y > 0 && rel_y > 0)
++                                { /* mouse s */
++                                    buf[0] = 0x68;
++                                    buf[1] = 0x82;
++                                    buf[2] = 0x91;
++                                }
++                                else if(context->key_y < 0 && rel_y < 0)
++                                { /* mouse n */
++                                    buf[0] = 0x69;
++                                    buf[1] = 0x02;
++                                    buf[2] = 0x81;
++                                }
++                            }
++                            else
++                            { /* mouse e/w*/
++                                if(context->key_x > 0 && rel_x > 0 )
++                                { /* mouse e */
++                                    buf[0] = 0x68;
++                                    buf[1] = 0x8A;
++                                    buf[2] = 0x81;
++                                }
++                                else if(context->key_x < 0 && rel_x < 0  )
++                                { /* mouse w */
++                                    buf[0] = 0x6A;
++                                    buf[1] = 0x82;
++                                    buf[2] = 0x81;
++                                }
++                            }
++                        }
++                        else
++                        {
++                            context->key_x += rel_x;
++                            context->key_y += rel_y;
++        
++                            return; /* discard those key codes */
++                        }
++                    }
++                    /* a key was pressed, reset count */
++                    context->key_x = 0;
++                    context->key_y = 0;
++                    context->last_count = 0;
++                }
++                
+ 		lirc_buffer_write_1(context->plugin->rbuf, buf);
+ 		wake_up(&context->plugin->rbuf->wait_poll);
+ 		return;
+diff -ruN lirc-0.8.3pre3-orig/drivers/lirc_imon/lirc_imon.c.rej lirc-0.8.3pre3/drivers/lirc_imon/lirc_imon.c.rej
+--- lirc-0.8.3pre3-orig/drivers/lirc_imon/lirc_imon.c.rej	1970-01-01 01:00:00.000000000 +0100
++++ lirc-0.8.3pre3/drivers/lirc_imon/lirc_imon.c.rej	2008-04-28 22:16:02.941653915 +0200
+@@ -0,0 +1,26 @@
++***************
++*** 271,280 ****
++  
++  MODULE_AUTHOR(MOD_AUTHOR);
++  MODULE_DESCRIPTION(MOD_DESC);
++  MODULE_LICENSE("GPL");
++  MODULE_DEVICE_TABLE(usb, imon_usb_id_table);
++  module_param(debug, int, 0);
++  MODULE_PARM_DESC(debug, "Debug messages: 0=no, 1=yes(default: no)");
++  
++  static inline void delete_context(struct imon_context *context)
++  {
++--- 279,291 ----
++  
++  MODULE_AUTHOR(MOD_AUTHOR);
++  MODULE_DESCRIPTION(MOD_DESC);
+++ MODULE_VERSION(MOD_VERSION);    /* MBr: was missing */
++  MODULE_LICENSE("GPL");
++  MODULE_DEVICE_TABLE(usb, imon_usb_id_table);
++  module_param(debug, int, 0);
++  MODULE_PARM_DESC(debug, "Debug messages: 0=no, 1=yes(default: no)");
+++ module_param (pad2keys_active, int, 0);
+++ MODULE_PARM_DESC (pad2keys_active, "pad2keys patch active: 0=no, 1=yes (default: no)");
++  
++  static inline void delete_context(struct imon_context *context)
++  {
+diff -ruN lirc-0.8.3pre3-orig/remotes/imon/lircd.conf.imon-pad2keys lirc-0.8.3pre3/remotes/imon/lircd.conf.imon-pad2keys
+--- lirc-0.8.3pre3-orig/remotes/imon/lircd.conf.imon-pad2keys	1970-01-01 01:00:00.000000000 +0100
++++ lirc-0.8.3pre3/remotes/imon/lircd.conf.imon-pad2keys	2008-04-28 22:16:02.941653915 +0200
+@@ -0,0 +1,88 @@
++# Please make this file available to others
++# by sending it to <lirc@bartelmus.de>
++#
++# this config file was generated
++# using lirc-0.8.3pre1 (imon w/pad2keys patch)
++#
++# contributed by M.Brakemeier
++#
++# brand:                       SoundGraph
++# model no. of remote control: iMON-PAD
++# devices being controlled by this remote:
++#
++
++begin remote
++
++  name     iMON-PAD
++  bits           32
++  eps            30
++  aeps          100
++
++  one             0     0
++  zero            0     0
++  gap          235965
++  min_repeat      1
++  toggle_bit      0
++
++    begin codes
++        AppExit                  0x288195B7
++        Power                    0x289115B7
++        Record                   0x298115B7
++        Play                     0x2A8115B7
++        Open                     0x29B1D5B7
++        Rewind                   0x2A8195B7
++        Pause                    0x2A9115B7
++        FastForward              0x2B8115B7
++        PrevChapter              0x2B9115B7
++        Stop                     0x2B9715B7
++        NextChapter              0x298195B7
++        Esc                      0x2BB715B7
++        Eject                    0x299395B7
++        AppLauncher              0x29B715B7
++        MultiMon                 0x2AB195B7
++        TaskSwitcher             0x2A9395B7
++        Mute                     0x2B9595B7
++        Vol+                     0x28A395B7
++        Vol-                     0x28A595B7
++        Ch+                      0x289395B7
++        Ch-                      0x288795B7
++        Timer                    0x2B8395B7
++        1                        0x28B595B7
++        2                        0x2BB195B7
++        3                        0x28B195B7
++        4                        0x2A8595B7
++        5                        0x299595B7
++        6                        0x2AA595B7
++        7                        0x2B9395B7
++        8                        0x2A8515B7
++        9                        0x2AA115B7
++        0                        0x2BA595B7
++        ShiftTab                 0x28B515B7
++        Tab                      0x29A115B7
++        Red                      0x2B8515B7 # MyMovie
++        Green                    0x299195B7 # MyMusic
++        Blue                     0x2BA115B7 # MyPhoto
++        Yellow                   0x28A515B7 # MyTV
++        Bookmark                 0x288515B7
++        Thumbnail                0x2AB715B7
++        AspectRatio              0x29A595B7
++        FullScreen               0x2AA395B7
++        Purple                   0x29A395B7 # MyDVD
++        Menu                     0x2BA395B7
++        Caption                  0x298595B7
++        Language                 0x2B8595B7
++        MouseKeyboard            0x299115B7
++        SelectSpace              0x2A9315B7
++        MouseMenu                0x28B715B7
++        MouseRightClick          0x688481B7
++        Enter                    0x28A195B7
++        MouseLeftClick           0x688301B7
++        WindowsKey               0x2B8195B7
++        Backspace                0x28A115B7
++        Mouse_N                  0x690281B7
++        Mouse_S                  0x688291B7
++        Mouse_W                  0x6A8281B7
++        Mouse_E                  0x688A81B7
++    end codes
++
++end remote 
diff --git a/app-misc/lirc/lirc-0.8.0-r8.ebuild b/app-misc/lirc/lirc-0.8.0-r8.ebuild
index aea1b8e4ac69..8f69b82e676b 100644
--- a/app-misc/lirc/lirc-0.8.0-r8.ebuild
+++ b/app-misc/lirc/lirc-0.8.0-r8.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.0-r8.ebuild,v 1.15 2007/10/13 09:20:15 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.0-r8.ebuild,v 1.16 2008/10/12 19:55:53 zzam Exp $
 
 inherit eutils linux-mod flag-o-matic autotools
 
-DESCRIPTION="LIRC is a package that allows you to decode and send infra-red \
-	signals of many (but not all) commonly used remote controls."
+DESCRIPTION="decode and send infra-red signals of many commonly used remote controls"
 HOMEPAGE="http://www.lirc.org"
 
 SLOT="0"
diff --git a/app-misc/lirc/lirc-0.8.4.ebuild b/app-misc/lirc/lirc-0.8.4.ebuild
new file mode 100644
index 000000000000..7d22c3bff34c
--- /dev/null
+++ b/app-misc/lirc/lirc-0.8.4.ebuild
@@ -0,0 +1,324 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.4.ebuild,v 1.1 2008/10/12 19:55:53 zzam Exp $
+
+inherit eutils linux-mod flag-o-matic autotools
+
+DESCRIPTION="decode and send infra-red signals of many commonly used remote controls"
+HOMEPAGE="http://www.lirc.org/"
+
+MY_P=${PN}-${PV/_/}
+
+if [[ "${PV/_pre/}" = "${PV}" ]]; then
+	SRC_URI="mirror://sourceforge/lirc/${MY_P}.tar.bz2"
+else
+	SRC_URI="http://lirc.sourceforge.net/software/snapshots/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc X hardware-carrier transmitter"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+	X? (
+		x11-libs/libX11
+		x11-libs/libSM
+		x11-libs/libICE
+	)
+	lirc_devices_alsa_usb? ( media-libs/alsa-lib )
+	lirc_devices_audio? ( media-libs/portaudio )
+	lirc_devices_irman? ( media-libs/libirman )"
+
+# This are drivers with names matching the
+# parameter --with-driver=NAME
+IUSE_LIRC_DEVICES_DIRECT="
+	all userspace accent act200l act220l
+	adaptec alsa_usb animax asusdh atilibusb
+	atiusb audio audio_alsa avermedia avermedia_vdomate
+	avermedia98 bestbuy bestbuy2 breakoutbox
+	bte bw6130 caraca chronos cmdir
+	cph06x creative creative_infracd
+	devinput digimatrix dsp dvico ea65
+	exaudio flyvideo gvbctv5pci hauppauge
+	hauppauge_dvb hercules_smarttv_stereo
+	igorplugusb imon imon_knob imon_lcd imon_pad imon_rsc
+	irdeo irdeo_remote irman irreal it87
+	knc_one kworld leadtek_0007 leadtek_0010
+	leadtek_pvr2000 livedrive_midi
+	livedrive_seq logitech macmini mceusb
+	mceusb2 mediafocusI mouseremote
+	mouseremote_ps2 mp3anywhere nslu2
+	packard_bell parallel pcmak pcmak_usb
+	pctv pixelview_bt878 pixelview_pak
+	pixelview_pro provideo realmagic
+	remotemaster sa1100 sasem sb0540 serial
+	silitek sir slinke streamzap tekram
+	tekram_bt829 tira ttusbir tuxbox tvbox udp uirt2
+	uirt2_raw usb_uirt_raw usbx
+	irlink commandir ite8709 samsung"
+
+# drivers that need special handling and
+# must have another name specified for
+# parameter --with-driver=NAME
+IUSE_LIRC_DEVICES_SPECIAL="
+	imon_pad2keys serial_igor_cesko
+	remote_wonder_plus xboxusb usbirboy inputlirc"
+
+IUSE_LIRC_DEVICES="${IUSE_LIRC_DEVICES_DIRECT} ${IUSE_LIRC_DEVICES_SPECIAL}"
+
+#device-driver which use libusb
+LIBUSB_USED_BY_DEV="
+	all atilibusb sasem igorplugusb imon imon_lcd imon_pad imon_pad2keys
+	imon_rsc streamzap mceusb mceusb2 xboxusb irlink commandir"
+
+for dev in ${LIBUSB_USED_BY_DEV}; do
+	RDEPEND="${RDEPEND} lirc_devices_${dev}? ( dev-libs/libusb )"
+done
+
+# adding only compile-time depends
+DEPEND="${RDEPEND}
+	virtual/linux-sources"
+
+# adding only run-time depends
+RDEPEND="${RDEPEND}
+	lirc_devices_usbirboy? ( app-misc/usbirboy )
+	lirc_devices_inputlirc? ( app-misc/inputlircd )"
+
+# add all devices to IUSE
+for dev in ${IUSE_LIRC_DEVICES}; do
+	IUSE="${IUSE} lirc_devices_${dev}"
+done
+
+add_device() {
+	: ${lirc_device_count:=0}
+	((lirc_device_count++))
+
+	if [[ ${lirc_device_count} -eq 2 ]]; then
+		ewarn
+		ewarn "When selecting multiple devices for lirc to be supported,"
+		ewarn "it can not be garanteed that the drivers play nice together."
+		ewarn
+		ewarn "If this is not intended, then abort emerge now with Ctrl-C,"
+		ewarn "Set LIRC_DEVICES and restart emerge."
+		ewarn
+		epause
+	fi
+
+	local dev="${1}"
+	local desc="device ${dev}"
+	if [[ -n "${2}" ]]; then
+		desc="${2}"
+	fi
+
+	elog "Compiling support for ${desc}"
+	MY_OPTS="${MY_OPTS} --with-driver=${dev}"
+}
+
+pkg_setup() {
+
+	CONFIG_CHECK="MODULES MODULE_UNLOAD"
+
+	linux-mod_pkg_setup
+
+	# set default configure options
+	MY_OPTS=""
+	LIRC_DRIVER_DEVICE="/dev/lirc0"
+
+	if use lirc_devices_all; then
+		# compile in drivers for a lot of devices
+		add_device all "a lot of devices"
+	else
+		# compile in only requested drivers
+		local dev
+		for dev in ${IUSE_LIRC_DEVICES_DIRECT}; do
+			if use lirc_devices_${dev}; then
+				add_device ${dev}
+			fi
+		done
+
+		if use lirc_devices_remote_wonder_plus; then
+			add_device atiusb "device Remote Wonder Plus (atiusb-based)"
+		fi
+
+		if use lirc_devices_serial_igor_cesko; then
+			add_device serial "serial with Igor Cesko design"
+			MY_OPTS="${MY_OPTS} --with-igor"
+		fi
+
+		if use lirc_devices_imon_pad2keys; then
+			add_device imon_pad "device imon_pad (with converting pad input to keyspresses)"
+			ewarn "You need to set the option pad2keys_active=1"
+			ewarn "when loading the module lirc_imon"
+		fi
+
+		if use lirc_devices_xboxusb; then
+			add_device atiusb "device xboxusb"
+		fi
+
+		if use lirc_devices_usbirboy; then
+			add_device userspace "device usbirboy"
+			LIRC_DRIVER_DEVICE="/dev/usbirboy"
+		fi
+
+		if [[ "${MY_OPTS}" == "" ]]; then
+			if [[ "${PROFILE_ARCH}" == "xbox" ]]; then
+				# on xbox: use special driver
+				add_device atiusb "device xboxusb"
+			else
+				# no driver requested
+				elog
+				elog "Compiling only the lirc-applications, but no drivers."
+				elog "Enable drivers with LIRC_DEVICES if you need them."
+				MY_OPTS="--with-driver=userspace"
+			fi
+		fi
+	fi
+
+	use hardware-carrier && MY_OPTS="${MY_OPTS} --without-soft-carrier"
+	use transmitter && MY_OPTS="${MY_OPTS} --with-transmitter"
+
+	if [[ -n "${LIRC_OPTS}" ]] ; then
+		ewarn
+		ewarn "LIRC_OPTS is deprecated from lirc-0.8.0-r1 on."
+		ewarn
+		ewarn "Please use LIRC_DEVICES from now on."
+		ewarn "e.g. LIRC_DEVICES=\"serial sir\""
+		ewarn
+		ewarn "Flags are now set per use-flags."
+		ewarn "e.g. transmitter, hardware-carrier"
+
+		local opt
+		local unsupported_opts=""
+
+		# test for allowed options for LIRC_OPTS
+		for opt in ${LIRC_OPTS}; do
+			case ${opt} in
+				--with-port=*|--with-irq=*|--with-timer=*|--with-tty=*)
+					MY_OPTS="${MY_OPTS} ${opt}"
+					;;
+				*)
+					unsupported_opts="${unsupported_opts} ${opt}"
+					;;
+			esac
+		done
+		if [[ -n ${unsupported_opts} ]]; then
+			ewarn "These options are no longer allowed to be set"
+			ewarn "with LIRC_OPTS: ${unsupported_opts}"
+			die "LIRC_OPTS is no longer recommended."
+		fi
+	fi
+
+	# Setup parameter for linux-mod.eclass
+	MODULE_NAMES="lirc(misc:${S})"
+	BUILD_TARGETS="all"
+
+	ECONF_PARAMS="	--localstatedir=/var
+			        --with-syslog=LOG_DAEMON
+			        --enable-sandboxed
+	    		    --with-kerneldir=${KV_DIR}
+			        --with-moduledir=/lib/modules/${KV_FULL}/misc
+	    		    $(use_enable debug)
+					$(use_with X x)
+					${MY_OPTS}"
+
+	einfo
+	einfo "lirc-configure-opts: ${MY_OPTS}"
+	elog  "Setting default lirc-device to ${LIRC_DRIVER_DEVICE}"
+
+	filter-flags -Wl,-O1
+
+	# force non-parallel make, Bug 196134
+	MAKEOPTS="${MAKEOPTS} -j1"
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	# Rip out dos CRLF
+	edos2unix contrib/lirc.rules
+
+	# Apply patches needed for some special device-types
+	epatch "${FILESDIR}"/${P}-imon-pad2keys.patch
+	use lirc_devices_remote_wonder_plus && epatch "${FILESDIR}"/lirc-0.8.3_pre1-remotewonderplus.patch
+
+	# remove parallel driver on SMP systems
+	if linux_chkconfig_present SMP ; then
+		sed -i -e "s:lirc_parallel\.o::" drivers/lirc_parallel/Makefile.am
+	fi
+
+	# Bug #187418
+	if kernel_is ge 2 6 22 ; then
+		ewarn "Disabling lirc_gpio driver as it does no longer work Kernel 2.6.22+"
+		sed -i -e "s:lirc_gpio\.o::" drivers/lirc_gpio/Makefile.am
+	fi
+
+	# respect CFLAGS
+	sed -i -e 's:CFLAGS="-O2:CFLAGS=""\n#CFLAGS="-O2:' configure.ac
+
+	# setting default device-node
+	local f
+	for f in configure.ac acconfig.h; do
+		[[ -f "$f" ]] && sed -i -e '/#define LIRC_DRIVER_DEVICE/d' "$f"
+	done
+	echo "#define LIRC_DRIVER_DEVICE \"${LIRC_DRIVER_DEVICE}\"" >> acconfig.h
+
+	eautoreconf
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "emake install failed"
+
+	newinitd "${FILESDIR}"/lircd-0.8.3 lircd
+	newinitd "${FILESDIR}"/lircmd lircmd
+	newconfd "${FILESDIR}"/lircd.conf.2 lircd
+
+	insinto /etc/modprobe.d/
+	newins "${FILESDIR}"/modprobed.lirc lirc
+
+	newinitd "${FILESDIR}"/irexec-initd irexec
+	newconfd "${FILESDIR}"/irexec-confd irexec
+
+	if use doc ; then
+		dohtml doc/html/*.html
+		insinto /usr/share/doc/${PF}/images
+		doins doc/images/*
+	fi
+
+	insinto /usr/share/lirc/remotes
+	doins -r remotes/*
+}
+
+pkg_preinst() {
+	linux-mod_pkg_preinst
+
+	# stop portage from deleting this file
+	if [[ -f ${ROOT}/etc/lircd.conf && ! -f ${D}/etc/lircd.conf ]]; then
+		cp "${ROOT}"/etc/lircd.conf "${D}"/etc/lircd.conf
+	fi
+}
+
+pkg_postinst() {
+	linux-mod_pkg_postinst
+	echo
+	elog "The lirc Linux Infrared Remote Control Package has been"
+	elog "merged, please read the documentation at http://www.lirc.org"
+	echo
+
+	if kernel_is ge 2 6 22 ; then
+		# Bug #187418
+		ewarn
+		ewarn "The lirc_gpio driver will not work with Kernels 2.6.22+"
+		ewarn "You need to switch over to /dev/input/event? if you need gpio"
+		ewarn "This device can than then be used via lirc's dev/input driver."
+		ewarn
+	fi
+
+	elog
+	elog "lirc now uses normal config-protection for lircd.conf."
+	elog "If you need any other lircd.conf you may have a look at"
+	elog "the directory /usr/share/lirc/remotes"
+}
-- 
cgit v1.2.3-65-gdbad