From b4e04ec944b8c2b881169ce88ed1400acd8f0ba0 Mon Sep 17 00:00:00 2001
From: Daniel Black <dragonheart@gentoo.org>
Date: Fri, 19 Nov 2004 13:47:24 +0000
Subject: version bump thanks to Andy <andyreif@studcs.uni-sb.de> in bug #71678

---
 dev-libs/blitz/blitz-0.8.ebuild | 43 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 dev-libs/blitz/blitz-0.8.ebuild

(limited to 'dev-libs/blitz/blitz-0.8.ebuild')

diff --git a/dev-libs/blitz/blitz-0.8.ebuild b/dev-libs/blitz/blitz-0.8.ebuild
new file mode 100644
index 000000000000..014268fe48dc
--- /dev/null
+++ b/dev-libs/blitz/blitz-0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.8.ebuild,v 1.1 2004/11/19 13:47:24 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="High-performance C++ numeric library"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.oonumerics.org/blitz"
+DEPEND="virtual/tetex
+	icc? ( dev-lang/icc )"
+IUSE="icc"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+src_unpack() {
+	unpack ${A}
+	cd ${S}
+	epatch ${FILESDIR}/blitz-0.8-makefile.patch || die "patch failed"
+}
+
+src_compile() {
+	local myconf
+	# ICC: if we've got it, use it
+	use icc && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
+
+	econf ${myconf} || die "econf failed"
+	if ! emake lib;
+	then
+		eerror 'If you got an error like "configure: error: Fortran 77 compiler cannot create executables'
+		die "Remerge gcc with the fortran use flag"
+	fi
+}
+
+src_install () {
+
+	emake DESTDIR=${D} docdir=/usr/share/doc/${PF} install || \
+		die "install failed - please include above output in a bug report to bugs.gentoo.org"
+	dodoc ChangeLog ChangeLog.1 LICENSE README README.binutils \
+	      TODO COPYING LEGAL AUTHORS NEWS
+}
-- 
cgit v1.2.3-65-gdbad