From af80af3f419d00e35ce5ebd2245d6012a7d7b069 Mon Sep 17 00:00:00 2001
From: Pacho Ramos <pacho@gentoo.org>
Date: Thu, 5 Sep 2013 20:01:45 +0000
Subject: Fix clang detection (#483412 by Stefan de Konink) and REQUIRED_USE
 (#471440 by Jonathan Callen)

(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
---
 dev-libs/gobject-introspection/ChangeLog           | 10 ++-
 ...gobject-introspection-1.36.0-detect-clang.patch | 27 +++++++
 .../gobject-introspection-1.36.0-r1.ebuild         | 82 ++++++++++++++++++++++
 3 files changed, 118 insertions(+), 1 deletion(-)
 create mode 100644 dev-libs/gobject-introspection/files/gobject-introspection-1.36.0-detect-clang.patch
 create mode 100644 dev-libs/gobject-introspection/gobject-introspection-1.36.0-r1.ebuild

(limited to 'dev-libs/gobject-introspection')

diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 6e46a56f0cb9..7c52ec9ea098 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,14 @@
 # ChangeLog for dev-libs/gobject-introspection
 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.94 2013/07/30 03:33:09 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.95 2013/09/05 20:01:42 pacho Exp $
+
+*gobject-introspection-1.36.0-r1 (05 Sep 2013)
+
+  05 Sep 2013; Pacho Ramos <pacho@gentoo.org>
+  +files/gobject-introspection-1.36.0-detect-clang.patch,
+  +gobject-introspection-1.36.0-r1.ebuild:
+  Fix clang detection (#483412 by Stefan de Konink) and REQUIRED_USE (#471440 by
+  Jonathan Callen)
 
   30 Jul 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
   gobject-introspection-1.32.1.ebuild, gobject-introspection-1.34.2-r1.ebuild:
diff --git a/dev-libs/gobject-introspection/files/gobject-introspection-1.36.0-detect-clang.patch b/dev-libs/gobject-introspection/files/gobject-introspection-1.36.0-detect-clang.patch
new file mode 100644
index 000000000000..8289ec07bdc7
--- /dev/null
+++ b/dev-libs/gobject-introspection/files/gobject-introspection-1.36.0-detect-clang.patch
@@ -0,0 +1,27 @@
+From 863ceb7f5a5b5f6accfea23dcd47b5c74a53f68b Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Thu, 02 May 2013 01:49:01 +0000
+Subject: Do not misdetect clang as the Microsoft C compiler
+
+Just because they both start with 'cl'.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=698090
+---
+diff --git a/giscanner/dumper.py b/giscanner/dumper.py
+index f5346a4..1ef1f4b 100644
+--- a/giscanner/dumper.py
++++ b/giscanner/dumper.py
+@@ -89,8 +89,9 @@ class DumpCompiler(object):
+         # Enable the --msvc-syntax pkg-config flag when
+         # the Microsoft compiler is used
+         # (This is the other way to check whether Visual C++ is used subsequently)
+-        if 'cl' in self._compiler_cmd:
+-            self._pkgconfig_msvc_flags = '--msvc-syntax'
++        if 'clang' not in self._compiler_cmd:
++            if 'cl' in self._compiler_cmd:
++                self._pkgconfig_msvc_flags = '--msvc-syntax'
+         self._uninst_srcdir = os.environ.get(
+             'UNINSTALLED_INTROSPECTION_SRCDIR')
+         self._packages = ['gio-2.0 gmodule-2.0']
+--
+cgit v0.9.2
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r1.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r1.ebuild
new file mode 100644
index 000000000000..2a733a056725
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r1.ebuild,v 1.1 2013/09/05 20:01:42 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome2 python-single-r1 toolchain-funcs
+
+DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="cairo doctool test"
+REQUIRED_USE="
+	${PYTHON_REQUIRED_USE}
+	test? ( cairo )
+"
+
+RDEPEND="
+	>=dev-libs/gobject-introspection-common-${PV}
+	>=dev-libs/glib-2.36:2
+	doctool? ( dev-python/mako )
+	virtual/libffi:=
+	!<dev-lang/vala-0.20.0
+"
+# Wants real bison, not virtual/yacc
+DEPEND="${RDEPEND}
+	>=dev-util/gtk-doc-am-1.15
+	sys-devel/bison
+	sys-devel/flex
+	virtual/pkgconfig
+"
+# PDEPEND to avoid circular dependencies, bug #391213
+PDEPEND="cairo? ( x11-libs/cairo[glib] )"
+
+pkg_setup() {
+	python-single-r1_pkg_setup
+}
+
+src_prepare() {
+	# Do not misdetect clang as the Microsoft C compiler (from 'master)
+	epatch "${FILESDIR}/${PN}-1.36.0-detect-clang.patch"
+
+	# To prevent crosscompiling problems, bug #414105
+	CC=$(tc-getCC)
+
+	DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
+	gnome2_src_prepare
+
+	# avoid GNU-isms
+	sed -i -e 's/\(if test .* \)==/\1=/' configure || die
+
+	if ! has_version "x11-libs/cairo[glib]"; then
+		# Bug #391213: enable cairo-gobject support even if it's not installed
+		# We only PDEPEND on cairo to avoid circular dependencies
+		export CAIRO_LIBS="-lcairo -lcairo-gobject"
+		export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+	fi
+}
+
+src_configure(){
+	gnome2_src_configure \
+		--disable-static \
+		YACC=$(type -p yacc) \
+		$(use_with cairo) \
+		$(use_enable doctool)
+}
+
+src_install() {
+	gnome2_src_install
+
+	# Prevent collision with gobject-introspection-common
+	rm -v "${ED}"usr/share/aclocal/introspection.m4 \
+		"${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
+	rmdir "${ED}"usr/share/aclocal || die
+}
-- 
cgit v1.2.3-65-gdbad