From db7851ffea635a6b1cf74c5a57789b4ac65cf69c Mon Sep 17 00:00:00 2001
From: Torsten Veller <tove@gentoo.org>
Date: Thu, 1 Sep 2011 14:09:02 +0000
Subject: Change version scheme

(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
---
 dev-perl/SOAP-Lite/ChangeLog                |  7 +++-
 dev-perl/SOAP-Lite/SOAP-Lite-0.712.0.ebuild | 54 +++++++++++++++++++++++++++++
 2 files changed, 60 insertions(+), 1 deletion(-)
 create mode 100644 dev-perl/SOAP-Lite/SOAP-Lite-0.712.0.ebuild

(limited to 'dev-perl')

diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index 126c98ea5912..549691f42fca 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for dev-perl/SOAP-Lite
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.66 2011/03/23 17:15:51 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.67 2011/09/01 14:09:02 tove Exp $
+
+*SOAP-Lite-0.712.0 (01 Sep 2011)
+
+  01 Sep 2011; Torsten Veller <tove@gentoo.org> +SOAP-Lite-0.712.0.ebuild:
+  Change version scheme
 
   23 Mar 2011; Christian Ruppert <idl0r@gentoo.org> SOAP-Lite-0.712.ebuild,
   +files/SOAP-Lite-0.712_sysread.patch:
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.712.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.712.0.ebuild
new file mode 100644
index 000000000000..f9346b0d62d0
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.712.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.712.0.ebuild,v 1.1 2011/09/01 14:09:02 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=MKUTTER
+MODULE_VERSION=0.712
+inherit perl-module eutils
+
+DESCRIPTION="Simple and lightweight interface to the SOAP protocol (sic) both on client and server side"
+
+IUSE="jabber ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="dev-perl/Class-Inspector
+	dev-perl/XML-Parser
+	dev-perl/libwww-perl
+	virtual/perl-libnet
+	dev-perl/MIME-Lite
+	virtual/perl-MIME-Base64
+	ssl? ( dev-perl/Crypt-SSLeay )
+	jabber? ( dev-perl/Net-Jabber )
+	ssl? ( dev-perl/IO-Socket-SSL )
+	virtual/perl-IO-Compress
+	>=dev-perl/MIME-tools-5.413
+	virtual/perl-version
+	dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+	# The author of this module put a dep for MIME::Parser 6.X - but the6.X
+	# release of MIME::Parser was a mistake during a change in maintainers on
+	# cpan. This patch alters the dependancy to the "real" stable version of
+	# MIME::Parser.
+	epatch "${FILESDIR}"/SOAP-Lite-0.710.08.patch
+	epatch "${FILESDIR}"/${PN}-0.712_sysread.patch
+}
+
+src_test() {
+	has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+	perl-module_src_test
+}
-- 
cgit v1.2.3-65-gdbad