From 86c9808cb0395fe5130ef75f8ef5d71b4dc9ea64 Mon Sep 17 00:00:00 2001
From: Gunnar Wrobel <wrobel@gentoo.org>
Date: Fri, 12 Oct 2007 12:35:33 +0000
Subject: -m Bump to tikiwiki-1.9.8.1. See sec issue #195503 (Portage version:
 2.1.2.12)

---
 www-apps/tikiwiki/ChangeLog                     |  7 ++-
 www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.1 |  3 +
 www-apps/tikiwiki/tikiwiki-1.9.8.1.ebuild       | 81 +++++++++++++++++++++++++
 3 files changed, 90 insertions(+), 1 deletion(-)
 create mode 100644 www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.1
 create mode 100644 www-apps/tikiwiki/tikiwiki-1.9.8.1.ebuild

(limited to 'www-apps')

diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 43d1e40fb244..81e9091f89fb 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for www-apps/tikiwiki
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.42 2007/09/17 17:47:47 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.43 2007/10/12 12:35:33 wrobel Exp $
+
+*tikiwiki-1.9.8.1 (12 Oct 2007)
+
+  12 Oct 2007; <wrobel@gentoo.org> +tikiwiki-1.9.8.1.ebuild:
+  -m Bump to tikiwiki-1.9.8.1. See sec issue #195503
 
   17 Sep 2007; <wrobel@gentoo.org> -tikiwiki-1.9.6.ebuild,
   -tikiwiki-1.9.7.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.1 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.1
new file mode 100644
index 000000000000..41a9bfbd5b57
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.8.1
@@ -0,0 +1,3 @@
+MD5 75f3fd02449bf8c3407bcb8947f6b149 tikiwiki-1.9.8.1.tar.bz2 6458011
+RMD160 090cab418e29cab860386bf65c89a088ae82e67c tikiwiki-1.9.8.1.tar.bz2 6458011
+SHA256 7670240177c4476698ab70a95e750428d06475e4595ddc361a636cb502f8b945 tikiwiki-1.9.8.1.tar.bz2 6458011
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.8.1.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.8.1.ebuild
new file mode 100644
index 000000000000..e605311600d0
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.8.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.8.1.ebuild,v 1.1 2007/10/12 12:35:33 wrobel Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/php
+	graphviz? ( media-gfx/graphviz )
+"
+pkg_setup () {
+	webapp_pkg_setup
+	use mysql && require_php_with_use mysql
+	use postgres && require_php_with_use postgres
+}
+
+src_install() {
+	webapp_src_preinst
+
+	local DIR
+	local DIRENTRY
+	local DIRS="backups db dump files img/trackers img/wiki
+		img/wiki_up modules/cache temp
+		templates_c templates styles maps whelp mods
+		lib/Galaxia/processes"
+
+	# Ensure that directories exist, some don't.
+	# (part of setup.sh)
+	for DIR in ${DIRS}; do
+		mkdir -p ${DIR}
+	done
+
+	# Remove the execute permission from the setup.sh script
+	# and rename it.  Its actions have been incorporated here.
+	chmod a-x setup.sh
+	mv setup.sh setup.sh.done
+
+	# Install the minimal doc (points to web page)
+	#
+	dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+	# The bulk goes into htdocs
+	# but don't copy INSTALL and README
+	cp -pPR [[:lower:]]* ${D}/${MY_HTDOCSDIR}
+
+	# Recursively set server ownership to allow server to write
+	# This is the rough equivalent of the setup.sh script
+	# provided in the distribution.
+	# Note: Cannot use xargs or find -exec here because
+	# these don't work with shell functions.
+	#
+	webapp_serverowned ${MY_HTDOCSDIR}
+	for DIR in ${DIRS}; do
+		find ${DIR} | while read DIRENTRY; do
+			webapp_serverowned ${MY_HTDOCSDIR}/${DIRENTRY}
+		done
+	done
+	webapp_serverowned  ${MY_HTDOCSDIR}/tiki-install.php
+
+	webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+	webapp_src_install
+}
+
+pkg_config() {
+	elog "Type in your MySQL root password to create an empty tiki database:"
+	mysqladmin -u root -p create tikiwiki
+}
+
+pkg_postinst() {
+	elog "To setup a MySQL database, run:"
+	elog "\"emerge --config =${PF}\""
+	elog "If you are using PostgreSQL, consult your documentation"
+	webapp_pkg_postinst
+}
-- 
cgit v1.2.3-65-gdbad