From c8f13357c5ffca7e1721c997c6a1b6265c4590d6 Mon Sep 17 00:00:00 2001
From: Gilles Dartiguelongue <eva@gentoo.org>
Date: Sun, 25 Jan 2009 23:16:36 +0000
Subject: Bump to 0.6.6. Bug fixes. (Portage version: 2.2_rc22/cvs/Linux
 2.6.24-gentoo-r8-mactel x86_64)

---
 x11-libs/goffice/ChangeLog            |  9 +++--
 x11-libs/goffice/goffice-0.6.6.ebuild | 62 +++++++++++++++++++++++++++++++++++
 2 files changed, 69 insertions(+), 2 deletions(-)
 create mode 100644 x11-libs/goffice/goffice-0.6.6.ebuild

(limited to 'x11-libs')

diff --git a/x11-libs/goffice/ChangeLog b/x11-libs/goffice/ChangeLog
index 4cc568fbf6a3..3a35d95e5a7f 100644
--- a/x11-libs/goffice/ChangeLog
+++ b/x11-libs/goffice/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for x11-libs/goffice
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.53 2008/09/28 07:59:23 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.54 2009/01/25 23:16:36 eva Exp $
+
+*goffice-0.6.6 (26 Jan 2009)
+
+  26 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org> +goffice-0.6.6.ebuild:
+  Bump to 0.6.6. Bug fixes.
 
   28 Sep 2008; Alexis Ballier <aballier@gentoo.org> goffice-0.6.5.ebuild:
   keyword ~x86-fbsd
diff --git a/x11-libs/goffice/goffice-0.6.6.ebuild b/x11-libs/goffice/goffice-0.6.6.ebuild
new file mode 100644
index 000000000000..3422a562bd1f
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.6.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.6.6.ebuild,v 1.1 2009/01/25 23:16:36 eva Exp $
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc gnome"
+
+# Raising glib dep to 2.14 to drop pcre dependency
+# cairo support broken and -gtk broken
+
+RDEPEND=">=dev-libs/glib-2.14
+	>=gnome-extra/libgsf-1.13.3
+	>=dev-libs/libxml2-2.4.12
+	>=x11-libs/pango-1.8.1
+	>=x11-libs/gtk+-2.6
+	>=gnome-base/libglade-2.3.6
+	>=media-libs/libart_lgpl-2.3.11
+	>=x11-libs/cairo-1.2
+	gnome? (
+		>=gnome-base/gconf-2
+		>=gnome-base/libgnomeui-2 )"
+
+DEPEND="${RDEPEND}
+	>=dev-util/pkgconfig-0.18
+	>=dev-util/intltool-0.35
+	doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+	G2CONF="${G2CONF} $(use_with gnome)"
+
+	local diemessage=""
+
+	if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+		eerror "Please rebuild gnome-extra/libgsf with gnome support enabled"
+		eerror "echo \"gnome-extra/libgsf gnome\" >> /etc/portage/package.use"
+		eerror "or add  \"gnome\" to your USE string in /etc/make.conf"
+		diemessage="No Gnome support found in libgsf."
+	fi
+
+	if ! built_with_use x11-libs/cairo svg ; then
+		eerror "Please rebuild x11-libs/cairo with svg support enabled"
+		eerror "echo \"x11-libs/cairo svg\" >> /etc/portage/package.use"
+		eerror "emerge -1 x11-libs/cairo"
+		diemessage="${diemessage} No SVG support found in cairo."
+	fi
+
+	[ -n "${diemessage}" ] && die ${diemessage}
+}
+
+src_compile() {
+	filter-flags -ffast-math
+	gnome2_src_compile
+}
-- 
cgit v1.2.3-65-gdbad