aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2021-03-23 20:47:40 +0100
committerGitHub <noreply@github.com>2021-03-23 20:47:40 +0100
commit94faa0724f8cbae6867c491c8e465e35f4fdbfbb (patch)
tree05590930e5ffbdc1e01be0aaf505d74cf3c49136 /configure.ac
parentbpo-41718: Update runpy startup time What's New (GH-24998) (diff)
downloadcpython-94faa0724f8cbae6867c491c8e465e35f4fdbfbb.tar.gz
cpython-94faa0724f8cbae6867c491c8e465e35f4fdbfbb.tar.bz2
cpython-94faa0724f8cbae6867c491c8e465e35f4fdbfbb.zip
bpo-43244: Remove ast.h, asdl.h, Python-ast.h headers (GH-24933)
These functions were undocumented and excluded from the limited C API. Most names defined by these header files were not prefixed by "Py" and so could create names conflicts. For example, Python-ast.h defined a "Yield" macro which was conflict with the "Yield" name used by the Windows <winbase.h> header. Use the Python ast module instead. * Move Include/asdl.h to Include/internal/pycore_asdl.h. * Move Include/Python-ast.h to Include/internal/pycore_ast.h. * Remove ast.h header file. * pycore_symtable.h no longer includes Python-ast.h.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4c3c80f74d2..e43b7733aed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ if test "$srcdir" != . -a "$srcdir" != "$(pwd)"; then
# If we're building out-of-tree, we need to make sure the following
# resources get picked up before their $srcdir counterparts.
# Objects/ -> typeslots.inc
- # Include/ -> Python-ast.h
+ # Include/ -> Python.h
# Python/ -> importlib.h
# (A side effect of this is that these resources will automatically be
# regenerated when building out-of-tree, regardless of whether or not