summaryrefslogtreecommitdiff
path: root/ijs
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-10 18:10:49 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-11 20:06:36 +0200
commitacfc02c1747065fe450c7cfeb6f1844b62335f08 (patch)
tree5887806a2e6b99bbb0255e013a9028810e230a7f /ijs
parentImport Ghostscript 9.52 (diff)
downloadghostscript-gpl-patches-acfc02c1747065fe450c7cfeb6f1844b62335f08.tar.gz
ghostscript-gpl-patches-acfc02c1747065fe450c7cfeb6f1844b62335f08.tar.bz2
ghostscript-gpl-patches-acfc02c1747065fe450c7cfeb6f1844b62335f08.zip
Import Ghostscript 9.53ghostscript-9.53
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'ijs')
-rw-r--r--ijs/Makefile.am2
-rw-r--r--ijs/configure.ac2
-rw-r--r--ijs/ijs.c2
-rw-r--r--ijs/ijs.h7
-rw-r--r--ijs/ijs_client.c2
-rw-r--r--ijs/ijs_client.h7
-rw-r--r--ijs/ijs_client_example.c2
-rw-r--r--ijs/ijs_exec_unix.c2
-rw-r--r--ijs/ijs_exec_win.c6
-rw-r--r--ijs/ijs_server.c2
-rw-r--r--ijs/ijs_server_example.c2
-rw-r--r--ijs/unistd_.h2
12 files changed, 24 insertions, 14 deletions
diff --git a/ijs/Makefile.am b/ijs/Makefile.am
index 433dff4b..9a0e148e 100644
--- a/ijs/Makefile.am
+++ b/ijs/Makefile.am
@@ -1,4 +1,4 @@
-## Copyright (C) 2001-2019 Artifex Software, Inc.
+## Copyright (C) 2001-2020 Artifex Software, Inc.
##
## Permission is hereby granted, free of charge, to any person
## obtaining a copy of this software and associated documentation
diff --git a/ijs/configure.ac b/ijs/configure.ac
index b37c3ef7..2417439f 100644
--- a/ijs/configure.ac
+++ b/ijs/configure.ac
@@ -1,4 +1,4 @@
-dnl Copyright (C) 2001-2019 Artifex Software, Inc.
+dnl Copyright (C) 2001-2020 Artifex Software, Inc.
dnl
dnl Permission is hereby granted, free of charge, to any person
dnl obtaining a copy of this software and associated documentation
diff --git a/ijs/ijs.c b/ijs/ijs.c
index b2120e8c..7226c557 100644
--- a/ijs/ijs.c
+++ b/ijs/ijs.c
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
diff --git a/ijs/ijs.h b/ijs/ijs.h
index 584c6ab1..9a03fdf4 100644
--- a/ijs/ijs.h
+++ b/ijs/ijs.h
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
@@ -22,6 +22,9 @@
* SOFTWARE.
**/
+#ifndef ijs_h_INCLUDED
+#define ijs_h_INCLUDED
+
/* This file contains common data types for IJS */
/* IJS_VERSION is decimal version number times 100 */
@@ -122,3 +125,5 @@ ijs_recv_int (IjsRecvChan *ch, int *val);
int
ijs_recv_block (IjsRecvChan *ch, char *buf, int buf_size);
+
+#endif
diff --git a/ijs/ijs_client.c b/ijs/ijs_client.c
index 6e5c335b..8e7a4a9b 100644
--- a/ijs/ijs_client.c
+++ b/ijs/ijs_client.c
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
diff --git a/ijs/ijs_client.h b/ijs/ijs_client.h
index 3bf49856..64fc6f90 100644
--- a/ijs/ijs_client.h
+++ b/ijs/ijs_client.h
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
@@ -22,6 +22,9 @@
* SOFTWARE.
**/
+#ifndef ijs_client_h_INCLUDED
+#define ijs_client_h_INCLUDED
+
#ifdef __cplusplus
extern "C" {
#endif
@@ -94,3 +97,5 @@ ijs_client_get_version (IjsClientCtx *ctx);
#ifdef __cplusplus
}
#endif
+
+#endif
diff --git a/ijs/ijs_client_example.c b/ijs/ijs_client_example.c
index 670ded7b..873761e3 100644
--- a/ijs/ijs_client_example.c
+++ b/ijs/ijs_client_example.c
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
diff --git a/ijs/ijs_exec_unix.c b/ijs/ijs_exec_unix.c
index cbfb6cdd..a517f8c4 100644
--- a/ijs/ijs_exec_unix.c
+++ b/ijs/ijs_exec_unix.c
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
diff --git a/ijs/ijs_exec_win.c b/ijs/ijs_exec_win.c
index 51ca4901..fc522002 100644
--- a/ijs/ijs_exec_win.c
+++ b/ijs/ijs_exec_win.c
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
@@ -76,9 +76,9 @@ ijs_exec_server(const char *server_cmd, int *pfd_to, int *pfd_from,
CloseHandle(hPipeTemp);
}
if (flag)
- flag = (fd_stdin_wr = _open_osfhandle((LONG)hChildStdinWr, _O_BINARY)) != -1;
+ flag = (fd_stdin_wr = _open_osfhandle((intptr_t)hChildStdinWr, _O_BINARY)) != -1;
if (flag)
- flag = (fd_stdout_rd = _open_osfhandle((LONG)hChildStdoutRd, _O_BINARY)) != -1;
+ flag = (fd_stdout_rd = _open_osfhandle((intptr_t)hChildStdoutRd, _O_BINARY)) != -1;
/* Now create the child process. */
if (flag) {
diff --git a/ijs/ijs_server.c b/ijs/ijs_server.c
index 39478fcd..ed41ee4b 100644
--- a/ijs/ijs_server.c
+++ b/ijs/ijs_server.c
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
diff --git a/ijs/ijs_server_example.c b/ijs/ijs_server_example.c
index 1b7b6942..f090e9fa 100644
--- a/ijs/ijs_server_example.c
+++ b/ijs/ijs_server_example.c
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation
diff --git a/ijs/unistd_.h b/ijs/unistd_.h
index 605895a5..bfba80f7 100644
--- a/ijs/unistd_.h
+++ b/ijs/unistd_.h
@@ -1,5 +1,5 @@
/**
- * Copyright (C) 2001-2019 Artifex Software, Inc.
+ * Copyright (C) 2001-2020 Artifex Software, Inc.
*
* Permission is hereby granted, free of charge, to any person
* obtaining a copy of this software and associated documentation