aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'doc/make.sh')
-rwxr-xr-xdoc/make.sh22
1 files changed, 7 insertions, 15 deletions
diff --git a/doc/make.sh b/doc/make.sh
index bf29d22..a330f17 100755
--- a/doc/make.sh
+++ b/doc/make.sh
@@ -17,31 +17,23 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-#Run this on developer side, and distribute troff
-#in case the end user doesn't have pod2man
+# This is run on the developer side with autogen.sh
-rm -f fix-gnustack.1
+PKG=$(cat ../configure.ac | grep ^AC_INIT | sed -e 's/^.*(\[//' -e 's/\].*$//')
+VERSION=$(cat ../configure.ac | grep ^AC_INIT | sed -e "s/^.*$PKG\], \[//" -e 's/\].*$//')
pod2man \
--official \
--section="1" \
- --release="elfix 0.3" \
+ --release="$PKG $VERSION" \
--center="Documentation for elfix" \
- --date="2011-04-14" \
- fix-gnustack.pod > fix-gnustack.1
-
-pod2man \
- --official \
- --section="1" \
- --release="elfix 0.3" \
- --center="Documentation for elfix" \
- --date="2011-08-18" \
+ --date=$(date +%Y-%m-%d) \
paxctl-ng.pod > paxctl-ng.1
pod2man \
--official \
--section="1" \
- --release="elfix 0.3" \
+ --release="$PKG $VERSION" \
--center="Documentation for elfix" \
- --date="2011-10-19" \
+ --date=$(date +%Y-%m-%d) \
revdep-pax.pod > revdep-pax.1