summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-10-31 09:30:55 +0100
committerUlrich Müller <ulm@gentoo.org>2016-10-31 09:30:55 +0100
commit6e078f8a6e665f473bbf96668f13871e6119e0d8 (patch)
tree7efaa5601346bedcd0ee461a618e6be519ff5bc6
parentUpdate version to 1.4.7. (diff)
downloadeselect-6e078f8a6e665f473bbf96668f13871e6119e0d8.tar.gz
eselect-6e078f8a6e665f473bbf96668f13871e6119e0d8.tar.bz2
eselect-6e078f8a6e665f473bbf96668f13871e6119e0d8.zip
Disable eval again.
* libs/core.bash.in (eval): Disable eval again, because the workaround for the rc module (sourcing functions.sh) is no longer needed. See also 2005-05-15 change by ciaranm. This partially reverts commit 76867bf1a47570cd9548100caed519252b5ced5a.
-rw-r--r--ChangeLog6
-rw-r--r--README2
-rw-r--r--libs/core.bash.in6
3 files changed, 13 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index c7a54f6..80bc483 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2016-10-31 Ulrich Müller <ulm@gentoo.org>
+
+ * libs/core.bash.in (eval): Disable eval again, because the
+ workaround for the rc module (sourcing functions.sh) is no longer
+ needed. See also 2005-05-15 change by ciaranm.
+
2016-10-30 Ulrich Müller <ulm@gentoo.org>
* configure.ac: Update version to 1.4.7.
diff --git a/README b/README
index 945dc41..de19882 100644
--- a/README
+++ b/README
@@ -34,7 +34,7 @@ Style Notes
one tab per indent level, with each tab representing 4 places.
* Avoid lines wider than 79 positions.
* Public functions don't get the ``es_`` prefix, private functions do.
-* eval is evil, so don't use it.
+* eval is evil, so we disabled it.
* Absolute paths to executables are not portable, so don't use them.
diff --git a/libs/core.bash.in b/libs/core.bash.in
index baddfde..da35ee9 100644
--- a/libs/core.bash.in
+++ b/libs/core.bash.in
@@ -119,6 +119,12 @@ inherit() {
done
}
+# make eval not work, because it's evil
+eval() {
+ write_warning_msg "Don't use eval. Find another way."
+ builtin eval "$@"
+}
+
# GNU sed wrapper (sed or gsed, as determined by configure)
sed() {
command @SED@ "$@"