aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Kelly <pioto@gentoo.org>2007-05-06 20:27:28 +0000
committerMike Kelly <pioto@gentoo.org>2007-05-06 20:27:28 +0000
commite564e81a3340fd53dc6387e54e44ae198e19a792 (patch)
tree175daef34be5c693bde0d2811e01ba8bc3c90f8d
parentSplit up gentoo-syntax (part 3). (diff)
downloadgentoo-syntax-e564e81a3340fd53dc6387e54e44ae198e19a792.tar.gz
gentoo-syntax-e564e81a3340fd53dc6387e54e44ae198e19a792.tar.bz2
gentoo-syntax-e564e81a3340fd53dc6387e54e44ae198e19a792.zip
Fix Bug #175135. Clean up the Makefile a bit. Update the ChangeLog.
svn path=/trunk/gentoo-syntax/; revision=32
-rw-r--r--Makefile2
-rw-r--r--doc/gentoo-syntax.txt9
-rw-r--r--plugin/newebuild.vim3
3 files changed, 10 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index c6552cf..c01bc3c 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
# Makefile for gentoo-syntax
distapp = gentoo-syntax
-distver := $(shell date --iso | sed -e 's~-~~g')
+distver := $(shell date -u +%Y%m%d)
distpkg := $(distapp)-$(distver)
PREFIX = ${HOME}/.vim/
diff --git a/doc/gentoo-syntax.txt b/doc/gentoo-syntax.txt
index 6136ca1..f9c1f92 100644
--- a/doc/gentoo-syntax.txt
+++ b/doc/gentoo-syntax.txt
@@ -273,6 +273,15 @@ Authors: Ciaran McCreesh <ciaranm at gentoo dot org>
==============================================================================
3. ChangeLog *gentoo-syntax-changelog*
+ 20070506 pioto
+ * Eclasses don't need to specify ECLASS or INHERITED anymore. See
+ Bug #175135.
+ * Split off eselect-specific stuff into the eselect-syntax
+ package, and portage configuration stuff into portage-syntax.
+ * Don't use GNU-specific date --iso in the Makefile, and be sure
+ that the version stamp is always from UTC.
+ * Release new version.
+
20070212 pioto
* Release new version.
diff --git a/plugin/newebuild.vim b/plugin/newebuild.vim
index e69658e..8c3313c 100644
--- a/plugin/newebuild.vim
+++ b/plugin/newebuild.vim
@@ -31,9 +31,6 @@ fun! <SID>MakeNewEbuild()
put ='# Purpose: '
put ='#'
put =''
- put ='ECLASS=\"' . l:eclass . '\"'
- put ='INHERITED=\"$INHERITED $ECLASS\"'
- put =''
" }}}
" {{{ go to the first thing to edit