aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2014-01-25 20:17:58 +0100
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2014-01-25 20:27:13 +0100
commitad250f4a1a862af7f673e043310f9635c3d9254e (patch)
tree2dc014c56694d66302f10681cdfa99c19d37849b
parent[kde-base/kdepim-common-libs] build all agents here (diff)
downloadkde-ad250f4a1a862af7f673e043310f9635c3d9254e.tar.gz
kde-ad250f4a1a862af7f673e043310f9635c3d9254e.tar.bz2
kde-ad250f4a1a862af7f673e043310f9635c3d9254e.zip
[kde-base/kmail] build no agents here
-rw-r--r--kde-base/kmail/Manifest1
-rw-r--r--kde-base/kmail/kmail-4.12.1-r1.ebuild104
-rw-r--r--kde-base/kmail/kmail-4.12.49.9999.ebuild4
-rw-r--r--kde-base/kmail/kmail-9999.ebuild4
4 files changed, 109 insertions, 4 deletions
diff --git a/kde-base/kmail/Manifest b/kde-base/kmail/Manifest
index 03fb79a041..5b732827e2 100644
--- a/kde-base/kmail/Manifest
+++ b/kde-base/kmail/Manifest
@@ -1 +1,2 @@
+DIST kdepim-4.12.1.tar.xz 14072572 SHA256 a357d1da332b294b8d2fbf29177a65eded9d9aef3a8e218a2c572b620aa9d7a3 SHA512 9e13b9c0ae25b9a5f9183f858d6aac84f2aaadf8feab6dc821232e6cf9309efe93b7baf157d1793e88c6e80f18f6d602e518535ed15bfaf79dfdf21c5c9af0b6 WHIRLPOOL 32a8b34952bf0d4cb9045ac7ab7dc71fda76967db942d14269912c6a8204904210d56a171c863e528754bbb7eb4a9ace125914e99c0cb56ed2a5072d925b3709
DIST kdepim-4.4.11.1.tar.bz2 8964708 SHA256 a2fa237a3d880cc55a6c94450b93a7918bb0d5e3943eb7a759c8789de1ed41bf SHA512 7450ba9985c5583847d1fc3d214940cef130150a3591c3cbb73bc15624ee0298805d5dc25f3cd3a135091c1d0491b865961d52aa8feef623219eed9364dd86bf WHIRLPOOL 349a72c5c6859c7cafb1aefdf80b80482102c8b1d6e0123c6c410d262c3908b9572daa1950e2fb41e6bc727430fc91bb57b7276e345553ed15d792fa63aba5ec
diff --git a/kde-base/kmail/kmail-4.12.1-r1.ebuild b/kde-base/kmail/kmail-4.12.1-r1.ebuild
new file mode 100644
index 0000000000..471fcb3823
--- /dev/null
+++ b/kde-base/kmail/kmail-4.12.1-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.12.1.ebuild,v 1.1 2014/01/18 11:23:39 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+VIRTUALX_REQUIRED=test
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+HOMEPAGE="http://www.kde.org/applications/internet/kmail/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs "" 4.12.1-r1)
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# bug 393147
+
+KMEXTRACTONLY="
+ agents/
+ akonadi_next/
+ calendarsupport/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ grantleetheme/
+ kaddressbookgrantlee/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ pimcommon/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+"
+KMEXTRA="
+ grantleethemeeditor/
+ headerthemeeditor/
+ kmailcvt/
+ ksendemail/
+ importwizard/
+ libksieve/
+ mailcommon/
+ mailimporter/
+ ontologies/
+ pimsettingexporter/
+ plugins/messageviewer/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+
+ if has_version "app-office/akonadi-server[sqlite]"; then
+ ewarn
+ ewarn "We strongly recommend you set your Akonadi database backend to QMYSQL in your"
+ ewarn "user configuration. This is the backend recommended by KDE upstream."
+ ewarn "Reports indicate that kde-base/kmail-4.10 does not work properly with the sqlite"
+ ewarn "backend anymore."
+ if has_version "app-office/akonadi-server[-mysql]"; then
+ ewarn "FOR THAT, YOU WILL HAVE TO RE-BUILD app-office/akonadi-server WITH mysql USEFLAG ENABLED."
+ fi
+ ewarn "You can select the backend in your ~/.config/akonadi/akonadiserverrc."
+ ewarn
+ fi
+}
diff --git a/kde-base/kmail/kmail-4.12.49.9999.ebuild b/kde-base/kmail/kmail-4.12.49.9999.ebuild
index a2c5774f8c..53760d69a0 100644
--- a/kde-base/kmail/kmail-4.12.49.9999.ebuild
+++ b/kde-base/kmail/kmail-4.12.49.9999.ebuild
@@ -17,7 +17,7 @@ IUSE="debug"
DEPEND="
$(add_kdebase_dep kdepimlibs)
$(add_kdebase_dep korganizer)
- $(add_kdebase_dep kdepim-common-libs)
+ $(add_kdebase_dep kdepim-common-libs "" 4.12.1-r1)
"
RDEPEND="${DEPEND}"
@@ -25,6 +25,7 @@ RESTRICT="test"
# bug 393147
KMEXTRACTONLY="
+ agents/
akonadi_next/
calendarsupport/
korganizer/
@@ -47,7 +48,6 @@ KMCOMPILEONLY="
calendarsupport/
"
KMEXTRA="
- agents/
grantleethemeeditor/
headerthemeeditor/
kmailcvt/
diff --git a/kde-base/kmail/kmail-9999.ebuild b/kde-base/kmail/kmail-9999.ebuild
index 0cdaf50198..fe80b17df6 100644
--- a/kde-base/kmail/kmail-9999.ebuild
+++ b/kde-base/kmail/kmail-9999.ebuild
@@ -17,7 +17,7 @@ IUSE="debug"
DEPEND="
$(add_kdebase_dep kdepimlibs)
$(add_kdebase_dep korganizer)
- $(add_kdebase_dep kdepim-common-libs)
+ $(add_kdebase_dep kdepim-common-libs "" 4.12.1-r1)
"
RDEPEND="${DEPEND}"
@@ -25,6 +25,7 @@ RESTRICT="test"
# bug 393147
KMEXTRACTONLY="
+ agents/
akonadi_next/
calendarsupport/
korganizer/
@@ -48,7 +49,6 @@ KMCOMPILEONLY="
noteshared/
"
KMEXTRA="
- agents/
grantleethemeeditor/
headerthemeeditor/
kmailcvt/