aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2010-05-16 16:24:53 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2010-05-16 16:24:53 +0000
commit1dd717b684376d571019b5ac47148e715e2fb13f (patch)
tree357e2d6300ea597c61d727c8a36e05466a0084c7 /media-sound
parent[kde-base/marble] Enable python bindings, cleanup a bit, move 4.4.2-r1 to tree (diff)
downloadkde-1dd717b684376d571019b5ac47148e715e2fb13f.tar.gz
kde-1dd717b684376d571019b5ac47148e715e2fb13f.tar.bz2
kde-1dd717b684376d571019b5ac47148e715e2fb13f.zip
[media-sound/amarok] Synchronized with tree version - dropped the bindist use flag as there's no issue with taglib licensing,
updated the mysql deps and added the warning about building without the embedded use flag.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/Manifest2
-rw-r--r--media-sound/amarok/amarok-9999.ebuild33
2 files changed, 26 insertions, 9 deletions
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index 1afd8caa36..0b07657dd1 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1,2 +1,2 @@
-EBUILD amarok-9999.ebuild 2641 RMD160 9651774ee7e9f9e95102577eb51dda167d8d7020 SHA1 2734599d8e805f59c6ad3c0a0b934e37d8c3be5f SHA256 2ed980adf5119640f5f2d393f3956c0a75ff0a942d043da3828d22fc63348ae4
+EBUILD amarok-9999.ebuild 3243 RMD160 fc2fb82096e2361b9e6a8003e535a0f8eba3d922 SHA1 08e72cdac57cd941752fb171867fb5ad6728da01 SHA256 180bd5128256a531499c59578e4435da3b045262b6f5a727a6cd13b334a7881f
MISC metadata.xml 2254 RMD160 837f618d570d8a0f917b7e1a21df8bfb28ba8458 SHA1 9e8df20b12e41e002625f97991af4af9e3ea5e0c SHA256 2f30895a93e73b7c7eae4f1cf6b5536bd9c21d163b5be2041c5179175b87e780
diff --git a/media-sound/amarok/amarok-9999.ebuild b/media-sound/amarok/amarok-9999.ebuild
index eb54d8419e..e58e7c6fa5 100644
--- a/media-sound/amarok/amarok-9999.ebuild
+++ b/media-sound/amarok/amarok-9999.ebuild
@@ -26,28 +26,25 @@ fi
LICENSE="GPL-2"
KEYWORDS=""
SLOT="4"
-IUSE="bindist cdda daap debug embedded ipod lastfm mp3tunes mtp semantic-desktop"
+IUSE="cdda daap debug embedded ipod lastfm mp3tunes mtp semantic-desktop"
# ipod requires gdk enabled and also gtk compiled in libgpod
DEPEND="
app-crypt/qca:2
- >=app-misc/strigi-0.5.7
- || (
- >=dev-db/mysql-5.0.76-r1[embedded?,-minimal]
- >=dev-db/mysql-community-5.0.77-r1[embedded?,-minimal]
- )
+ >=app-misc/strigi-0.5.7[dbus,qt4]
+ >=dev-db/mysql-5.0.76
+ >=media-libs/taglib-1.6.1[asf,mp4]
>=media-libs/taglib-extras-1.0.1
>=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
sys-libs/zlib
x11-libs/qt-script
>=x11-libs/qtscriptgenerator-0.1.0
- bindist? ( >=media-libs/taglib-1.6.1[-asf,-mp4] )
- !bindist? ( >=media-libs/taglib-1.6.1[asf,mp4] )
cdda? (
>=kde-base/libkcddb-${KDE_MINIMAL}
>=kde-base/libkcompactdisc-${KDE_MINIMAL}
>=kde-base/kdemultimedia-kioslaves-${KDE_MINIMAL}
)
+ embedded? ( <dev-db/mysql-5.1[embedded,-minimal] )
ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
lastfm? ( >=media-libs/liblastfm-0.3.0 )
mp3tunes? (
@@ -66,6 +63,10 @@ RDEPEND="${DEPEND}
semantic-desktop? ( >=kde-base/nepomuk-${KDE_MINIMAL} )
"
+# Tests require gmock - http://code.google.com/p/gmock/
+# It's not in the tree yet
+RESTRICT="test"
+
# Only really required for live ebuild, to skip git_src_prepare
src_prepare() {
kde4-base_src_prepare
@@ -98,4 +99,20 @@ pkg_postinst() {
elog "You may be interested in installing www-servers/mongrel as well."
echo
fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amaroklive.com/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "dev-db/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
}