aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycups/pycups-1.9.45.ebuild')
-rw-r--r--dev-python/pycups/pycups-1.9.45.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/pycups/pycups-1.9.45.ebuild b/dev-python/pycups/pycups-1.9.45.ebuild
deleted file mode 100644
index c05ed0cdb5..0000000000
--- a/dev-python/pycups/pycups-1.9.45.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-NEED_PYTHON="2.4"
-inherit python
-
-DESCRIPTION="Python bindings for the CUPS API"
-HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
-SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-RDEPEND="
- net-print/cups
-"
-DEPEND="${RDEPEND}
- doc? ( dev-python/epydoc )
-"
-
-src_compile() {
- python_version
- emake PYTHONVERS="python${PYVER}" || die "emake failed"
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- dodoc NEWS README TODO || die "dodoc failed"
-
- if use doc; then
- dohtml -r html/ || die "installing html docs failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/"${P}"
- doins -r examples/ || die "installing examples failed"
- fi
-
- emake DESTDIR="${D}" install || die "emake install failed"
-}