aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/krunner/krunner-4.5.95.ebuild')
-rw-r--r--kde-base/krunner/krunner-4.5.95.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/kde-base/krunner/krunner-4.5.95.ebuild b/kde-base/krunner/krunner-4.5.95.ebuild
new file mode 100644
index 0000000000..0aeb793024
--- /dev/null
+++ b/kde-base/krunner/krunner-4.5.95.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Command Runner"
+IUSE="debug"
+KEYWORDS="~amd64 ~x86"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kcheckpass)
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep ksmserver)
+ $(add_kdebase_dep ksysguard)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep libplasmagenericshell)
+ !aqua? (
+ x11-libs/libXxf86misc
+ x11-libs/libXcursor
+ x11-libs/libXScrnSaver
+ )
+"
+DEPEND="${COMMONDEPEND}
+ !aqua? (
+ x11-libs/libXcursor
+ x11-proto/xf86miscproto
+ x11-proto/scrnsaverproto
+ )
+"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRACTONLY="
+ libs/kdm/
+ libs/kephal/
+ libs/ksysguard/
+ libs/kworkspace/
+ libs/plasmagenericshell/
+ kcheckpass/
+ ksmserver/org.kde.KSMServerInterface.xml
+ ksysguard/
+ plasma/screensaver/shell/org.kde.plasma-overlay.App.xml
+"
+
+KMLOADLIBS="libkworkspace"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}