aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-systemmonitor/plasma-systemmonitor-9999.ebuild')
-rw-r--r--kde-plasma/plasma-systemmonitor/plasma-systemmonitor-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-systemmonitor/plasma-systemmonitor-9999.ebuild b/kde-plasma/plasma-systemmonitor/plasma-systemmonitor-9999.ebuild
new file mode 100644
index 0000000000..1a52269774
--- /dev/null
+++ b/kde-plasma/plasma-systemmonitor/plasma-systemmonitor-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.74.0
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="New version of KSysGuard built on top of the new KStats daemon and using QML"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-systemmonitor"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="5"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ kde-plasma/libksysguard:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5[qml]
+ >=kde-frameworks/kquickcharts-${KFMIN}:5
+"