aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2012-02-02 01:28:28 +0100
committerEric Blake <eblake@redhat.com>2012-02-01 17:37:45 -0700
commit02ee87451bef0651bbf9f1fda36602f88754d950 (patch)
tree0658a5c665312daa2a5976ba97822abebf80d729 /bootstrap
parenttests: dynamically replace dnsmasq path (diff)
downloadlibvirt-02ee87451bef0651bbf9f1fda36602f88754d950.tar.gz
libvirt-02ee87451bef0651bbf9f1fda36602f88754d950.tar.bz2
libvirt-02ee87451bef0651bbf9f1fda36602f88754d950.zip
Update gnulib to fix mingw64 compilation errors
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap16
1 files changed, 12 insertions, 4 deletions
diff --git a/bootstrap b/bootstrap
index 2a409fcd6..6910abfad 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,6 +1,6 @@
#! /bin/sh
# Print a version string.
-scriptversion=2012-01-16.17; # UTC
+scriptversion=2012-01-21.16; # UTC
# Bootstrap this package from checked-out sources.
@@ -87,9 +87,9 @@ gnulib_files=
: ${AUTOPOINT=autopoint}
: ${AUTORECONF=autoreconf}
-# A function to be called to edit gnulib.mk right after it's created.
+# A function to be called right after gnulib-tool is run.
# Override it via your own definition in bootstrap.conf.
-gnulib_mk_hook() { :; }
+bootstrap_post_import_hook() { :; }
# A function to be called after everything else in this script.
# Override it via your own definition in bootstrap.conf.
@@ -807,6 +807,9 @@ for file in $gnulib_files; do
symlink_to_dir "$GNULIB_SRCDIR" $file || exit
done
+bootstrap_post_import_hook \
+ || { echo >&2 "$me: bootstrap_post_import_hook failed"; exit 1; }
+
# Remove any dangling symlink matching "*.m4" or "*.[ch]" in some
# gnulib-populated directories. Such .m4 files would cause aclocal to fail.
# The following requires GNU find 4.2.3 or newer. Considering the usual
@@ -819,11 +822,16 @@ find "$m4_base" "$source_base" \
-depth \( -name '*.m4' -o -name '*.[ch]' \) \
-type l -xtype l -delete > /dev/null 2>&1
-# Tell autoreconf not to invoke autopoint or libtoolize; they were run above.
+# Some systems (RHEL 5) are using ancient autotools, for which the
+# --no-recursive option had not been invented. Detect that lack and
+# omit the option when it's not supported. FIXME in 2017: remove this
+# hack when RHEL 5 autotools are updated, or when they become irrelevant.
no_recursive=
case $($AUTORECONF --help) in
*--no-recursive*) no_recursive=--no-recursive;;
esac
+
+# Tell autoreconf not to invoke autopoint or libtoolize; they were run above.
echo "running: AUTOPOINT=true LIBTOOLIZE=true " \
"$AUTORECONF --verbose --install $no_recursive -I $m4_base $ACLOCAL_FLAGS"
AUTOPOINT=true LIBTOOLIZE=true \