aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-03-16 15:25:56 -0600
committerEric Blake <eblake@redhat.com>2011-03-23 15:51:32 -0600
commit2d24037db0ae976a9bfe0eca561524749cca58e9 (patch)
tree6a3d7d6c10c2a4d116027f038622b47f1a8996e7 /bootstrap
parentcommand: reject pidfile on non-daemon (diff)
downloadlibvirt-2d24037db0ae976a9bfe0eca561524749cca58e9.tar.gz
libvirt-2d24037db0ae976a9bfe0eca561524749cca58e9.tar.bz2
libvirt-2d24037db0ae976a9bfe0eca561524749cca58e9.zip
build: nuke all .x-sc* files, and fix VPATH syntax-check
Not every day you see a patch that nukes 27 files! * .gnulib: Update to latest, for maint.mk improvements * bootstrap: Resync to gnulib. * bootstrap.conf (ACLOCAL): Swap the secondary aclocal include directory, now that bootstrap picks up gnulib/m4 instead of m4. * Makefile.am (syntax_check_exceptions, EXTRA_DIST): No longer worry about nuked files. * cfg.mk (sc_x_sc_dist_check): Delete dead rule. (VC_LIST_ALWAYS_EXCLUDE_REGEX): Add HACKING. (exclude_file_name_regexp--sc_*): Inline and simplify contents... * .x-sc_*: ...from here, then delete the files.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap6
1 files changed, 3 insertions, 3 deletions
diff --git a/bootstrap b/bootstrap
index e9ec11ea4..f004ad326 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,6 +1,6 @@
#! /bin/sh
# Print a version string.
-scriptversion=2011-01-21.16; # UTC
+scriptversion=2011-03-03.12; # UTC
# Bootstrap this package from checked-out sources.
@@ -874,7 +874,7 @@ grep -E '^[ ]*AC_CONFIG_HEADERS?\>' configure.ac >/dev/null ||
for command in \
libtool \
- "${ACLOCAL-aclocal} --force -I m4 $ACLOCAL_FLAGS" \
+ "${ACLOCAL-aclocal} --force -I '$m4_base' $ACLOCAL_FLAGS" \
"${AUTOCONF-autoconf} --force" \
"${AUTOHEADER-autoheader} --force" \
"${AUTOMAKE-automake} --add-missing --copy --force-missing"
@@ -885,7 +885,7 @@ do
command="${LIBTOOLIZE-libtoolize} -c -f"
fi
echo "$0: $command ..."
- $command || exit
+ eval "$command" || exit
done