aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-01-16 10:23:32 -0700
committerEric Blake <eblake@redhat.com>2012-01-16 11:23:34 -0700
commit9a070e8341d807bad353abe1215ea18ad216fec3 (patch)
treeefe90d2791e302a5bc8776d2baab9cff0099f2ea /bootstrap
parentdocs: Expose alias tag in domain RNG schema (diff)
downloadlibvirt-9a070e8341d807bad353abe1215ea18ad216fec3.tar.gz
libvirt-9a070e8341d807bad353abe1215ea18ad216fec3.tar.bz2
libvirt-9a070e8341d807bad353abe1215ea18ad216fec3.zip
build: fix bootstrap on fresh clone
Commit 29db7a0 picked up a gnulib bug, where a change in bootstrap meant that it would fail to run libtoolize on projects, like libvirt, that used the older spelling AM_PROG_LIBTOOL instead of LT_INIT for the sake of building on RHEL 5. Now that gnulib is fixed, we should pick up that fix. * .gnulib: Update to latest, for bootstrap fix. * bootstrap: Resync from gnulib.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap12
1 files changed, 8 insertions, 4 deletions
diff --git a/bootstrap b/bootstrap
index 66da98103..2a409fcd6 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,6 +1,6 @@
#! /bin/sh
# Print a version string.
-scriptversion=2012-01-06.07; # UTC
+scriptversion=2012-01-16.17; # UTC
# Bootstrap this package from checked-out sources.
@@ -758,7 +758,7 @@ fi
# Autoreconf runs aclocal before libtoolize, which causes spurious
# warnings if the initial aclocal is confused by the libtoolized
# (or worse out-of-date) macro directory.
-if grep '^[ ]*LT_INIT' configure.ac >/dev/null; then
+if test $use_libtool = 1; then
echo "running: $LIBTOOLIZE --copy --install"
$LIBTOOLIZE --copy --install
fi
@@ -820,10 +820,14 @@ find "$m4_base" "$source_base" \
-type l -xtype l -delete > /dev/null 2>&1
# Tell autoreconf not to invoke autopoint or libtoolize; they were run above.
+no_recursive=
+case $($AUTORECONF --help) in
+ *--no-recursive*) no_recursive=--no-recursive;;
+esac
echo "running: AUTOPOINT=true LIBTOOLIZE=true " \
- "$AUTORECONF --verbose --install --no-recursive -I $m4_base $ACLOCAL_FLAGS"
+ "$AUTORECONF --verbose --install $no_recursive -I $m4_base $ACLOCAL_FLAGS"
AUTOPOINT=true LIBTOOLIZE=true \
- $AUTORECONF --verbose --install --no-recursive -I $m4_base $ACLOCAL_FLAGS \
+ $AUTORECONF --verbose --install $no_recursive -I $m4_base $ACLOCAL_FLAGS \
|| exit 1
# Get some extra files from gnulib, overriding existing files.