aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2012-04-04 11:16:34 +0100
committerDaniel P. Berrange <berrange@redhat.com>2012-04-04 19:31:40 +0100
commite7eca6e4be5175ec127a4327462b4374953b9bc5 (patch)
tree061f20785f47d4e5bf318985e4793681322f8efe /configure.ac
parentFix parallel build in docs/ directory (diff)
downloadlibvirt-e7eca6e4be5175ec127a4327462b4374953b9bc5.tar.gz
libvirt-e7eca6e4be5175ec127a4327462b4374953b9bc5.tar.bz2
libvirt-e7eca6e4be5175ec127a4327462b4374953b9bc5.zip
Don't install sysctl file on non-Linux hosts
* configure.ac: Set WITH_SYSCTL only on Linux hosts * daemon/Makefile.am: Conditionalize install-sysctl using WITH_SYSCTL Signed-off-by: Daniel P. Berrange <berrange@redhat.com> Cc: Jason Helfman <jhelfman@e-e.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0e83019a3..3f5b3ffec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,6 +403,31 @@ AM_CONDITIONAL([LIBVIRT_INIT_SCRIPT_UPSTART], test "$init_upstart" = "yes")
AM_CONDITIONAL([LIBVIRT_INIT_SCRIPT_SYSTEMD], test "$init_systemd" = "yes")
AC_MSG_RESULT($with_init_script)
+
+AC_MSG_CHECKING([for whether to install sysctl config])
+AC_ARG_WITH([sysctl],
+ [AC_HELP_STRING([--with-sysctl@<:@=yes/no@:>@],
+ [Whether to install sysctl configs @<:@default=auto@:>@])],
+ [],[with_sysctl=check])
+
+if test "$with_sysctl" = "yes" || test "$with_sysctl" = "check"
+then
+ case $host in
+ *-*-linux*)
+ with_sysctl=yes
+ ;;
+ **)
+ if test "$with_sysctl" = "yes"; then
+ AC_MSG_ERROR([No sysctl configuration supported for $host])
+ else
+ with_sysctl=no
+ fi
+ ;;
+ esac
+fi
+AM_CONDITIONAL([WITH_SYSCTL], test "$with_sysctl" = "yes")
+AC_MSG_RESULT($with_sysctl)
+
dnl RHEL-5 has a peculiar version of Xen, which requires some special casing
AC_ARG_WITH([rhel5-api],
[AC_HELP_STRING([--with-rhel5-api=@<:@ARG@:>@],