aboutsummaryrefslogtreecommitdiff
path: root/src/libxl
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-07-19 12:32:58 -0600
committerEric Blake <eblake@redhat.com>2011-07-21 10:34:51 -0600
commit8e22e08935655e5b39873bc8e1aa41d2ef2f8487 (patch)
tree842771f0ff7afff72077720ada521d40e63c8f08 /src/libxl
parentcommand: avoid leaking fds across fork (diff)
downloadlibvirt-8e22e08935655e5b39873bc8e1aa41d2ef2f8487.tar.gz
libvirt-8e22e08935655e5b39873bc8e1aa41d2ef2f8487.tar.bz2
libvirt-8e22e08935655e5b39873bc8e1aa41d2ef2f8487.zip
build: rename files.h to virfile.h
In preparation for a future patch adding new virFile APIs. * src/util/files.h, src/util/files.c: Move... * src/util/virfile.h, src/util/virfile.c: ...here, and rename functions to virFile prefix. Macro names are intentionally left alone. * *.c: All '#include "files.h"' uses changed. * src/Makefile.am (UTIL_SOURCES): Reflect rename. * cfg.mk (exclude_file_name_regexp--sc_prohibit_close): Likewise. * src/libvirt_private.syms: Likewise. * docs/hacking.html.in: Likewise. * HACKING: Regenerate.
Diffstat (limited to 'src/libxl')
-rw-r--r--src/libxl/libxl_conf.c2
-rw-r--r--src/libxl/libxl_driver.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/src/libxl/libxl_conf.c b/src/libxl/libxl_conf.c
index 0f6035eda..b74a4b1d5 100644
--- a/src/libxl/libxl_conf.c
+++ b/src/libxl/libxl_conf.c
@@ -34,7 +34,7 @@
#include "logging.h"
#include "virterror_internal.h"
#include "datatypes.h"
-#include "files.h"
+#include "virfile.h"
#include "memory.h"
#include "uuid.h"
#include "capabilities.h"
diff --git a/src/libxl/libxl_driver.c b/src/libxl/libxl_driver.c
index d52a8b695..381d90b59 100644
--- a/src/libxl/libxl_driver.c
+++ b/src/libxl/libxl_driver.c
@@ -36,7 +36,7 @@
#include "virterror_internal.h"
#include "conf.h"
#include "datatypes.h"
-#include "files.h"
+#include "virfile.h"
#include "memory.h"
#include "uuid.h"
#include "command.h"