summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-12-23 03:38:16 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-12-23 03:38:16 +0700
commit55ccb8c324c95647b198fce6b516686d16f22bfb (patch)
treedc65f3743bce9c8bce06242ec5a8544b02512f71 /dev-lua/lapis
parent[dev-lua/lullaby] Added (diff)
downloadlua-55ccb8c324c95647b198fce6b516686d16f22bfb.tar.gz
lua-55ccb8c324c95647b198fce6b516686d16f22bfb.tar.bz2
lua-55ccb8c324c95647b198fce6b516686d16f22bfb.zip
[dev-lua/lapis] (+ dependencies, including MoonScript) Added
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'dev-lua/lapis')
-rw-r--r--dev-lua/lapis/lapis-9999.ebuild57
-rw-r--r--dev-lua/lapis/metadata.xml14
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-lua/lapis/lapis-9999.ebuild b/dev-lua/lapis/lapis-9999.ebuild
new file mode 100644
index 0000000..c959d04
--- /dev/null
+++ b/dev-lua/lapis/lapis-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: This ebuild is from Lua overlay; Bumped by mva; $
+
+EAPI="5"
+
+inherit base toolchain-funcs git-r3
+
+DESCRIPTION="A web framework for Lua/MoonScript."
+HOMEPAGE="https://github.com/leafo/lapis"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/leafo/lapis"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="luajit moonscript"
+
+RDEPEND="
+ !luajit? ( >=dev-lang/lua-5.1 )
+ luajit? ( dev-lang/luajit:2 )
+ moonscript? ( dev-lua/moonscript )
+ dev-lua/ansicolors
+ dev-lua/luasocket
+ dev-lua/luacrypto
+ dev-lua/lua-cjson
+ dev-lua/lpeg
+ dev-lua/rds-parser
+ dev-lua/resty-upload
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+HTML_DOCS=( "docs/" "README.md" )
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ local lua=lua;
+ use luajit && lua=luajit;
+
+ use moonscript || find "${S}" -type -name '*.moon' -delete
+
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD ${lua})"
+ doins -r lapis
+
+ dobin bin/lapis
+
+ use moonscript && doins lapis.moon
+
+ base_src_install_docs
+} \ No newline at end of file
diff --git a/dev-lua/lapis/metadata.xml b/dev-lua/lapis/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/lapis/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>