aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Lezcano <daniel.lezcano@free.fr>2009-10-12 22:02:06 +0200
committerDaniel Lezcano <dlezcano@fr.ibm.com>2009-10-12 22:02:06 +0200
commita1511e8d159b0cb694bfd5376091afca8fe8c8c1 (patch)
treefb761e55e25716f892d7d7aed0398b5fe7b15164
parentremove configure dead code (diff)
downloadlxc-a1511e8d159b0cb694bfd5376091afca8fe8c8c1.tar.gz
lxc-a1511e8d159b0cb694bfd5376091afca8fe8c8c1.tar.bz2
lxc-a1511e8d159b0cb694bfd5376091afca8fe8c8c1.zip
fix compilation error for tests
Fix test program compilation errors. Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
-rw-r--r--test/Makefile.am5
-rw-r--r--test/ipv6_add.c12
-rw-r--r--test/lxc_create.c112
-rw-r--r--test/lxc_monitor.c99
4 files changed, 13 insertions, 215 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index b916869..e84ab12 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -21,7 +21,6 @@ noinst_PROGRAMS = \
lxc_destroy \
lxc_start \
lxc_stop \
- lxc_monitor \
lxc_low_monitor \
lxc_state
@@ -87,10 +86,6 @@ lxc_stop_SOURCES = lxc_stop.c
lxc_stop_LDADD = \
$(top_builddir)/src/lxc/liblxc.la
-lxc_monitor_SOURCES = lxc_monitor.c
-lxc_monitor_LDADD = \
- $(top_builddir)/src/lxc/liblxc.la
-
lxc_low_monitor_SOURCES = lxc_low_monitor.c
lxc_low_monitor_LDADD = \
$(top_builddir)/src/lxc/liblxc.la
diff --git a/test/ipv6_add.c b/test/ipv6_add.c
index 13de06f..5e7582a 100644
--- a/test/ipv6_add.c
+++ b/test/ipv6_add.c
@@ -26,7 +26,8 @@
#include <errno.h>
#include <sys/types.h>
#include <sys/socket.h>
-
+#include <net/if.h>
+#include <arpa/inet.h>
#include <lxc/network.h>
void usage(char *cmd)
@@ -37,6 +38,7 @@ void usage(char *cmd)
int main(int argc, char *argv[])
{
char *ifname = NULL, *addr = NULL;
+ struct in6_addr in6;
int opt, ret = -EINVAL;
while ((opt = getopt(argc, argv, "i:a:")) != -1) {
@@ -55,7 +57,13 @@ int main(int argc, char *argv[])
return 1;
}
- ret = lxc_ip6_addr_add(ifname, addr, 64, NULL);
+ if (inet_pton(AF_INET6, addr, &in6)) {
+ perror("inet_pton");
+ return 1;
+ }
+
+ ret = lxc_ip_addr_add(AF_INET6, if_nametoindex(ifname),
+ &in6, 64);
if (ret) {
fprintf(stderr, "failed to set %s: %s\n",
ifname, strerror(-ret));
diff --git a/test/lxc_create.c b/test/lxc_create.c
index bac0bf9..d4aea98 100644
--- a/test/lxc_create.c
+++ b/test/lxc_create.c
@@ -42,116 +42,8 @@ int main(int argc, char *argv[])
{
const char *name = NULL;
int opt;
-
-/* struct list mclist; */
-/* struct list mclist2; */
-/* struct list vethlist; */
-/* struct list vethlist2; */
- struct lxc_list phylist;
-/* struct inetdev idev; */
-/* struct list l1 = init_list(&l1); */
-/* l1.elem = &idev; */
-
-/* struct inetdev idev_2; */
-/* struct list l2 = init_list(&l2); */
-/* l2.elem = &idev_2; */
-
-/* struct inet6dev idev6; */
-/* struct list l3 = init_list(&l3); */
-/* l3.elem = &idev6; */
-
-/* struct inet6dev idev6_2; */
-/* struct list l4 = init_list(&l4); */
-/* l4.elem = idev6_2; */
-
-
-/* inet_pton(AF_INET, "1.2.3.4", &idev.addr); */
-/* inet_pton(AF_INET, "1.2.3.255", &idev.bcast); */
-/* idev.prefix = 24; */
-
-/* inet_pton(AF_INET, "4.3.2.1", &idev_2.addr); */
-/* inet_pton(AF_INET, "4.3.2.255", &idev_2.bcast); */
-
-/* inet_pton(AF_INET6, "2003:db8:1:0:214:5eff:fe0b:3596", &idev6.addr); */
-/* inet_pton(AF_INET6, "2003:db8:1:0:214:1234:fe0b:3596", &idev6_2.addr); */
-
-/* struct network veth = { */
-/* .type = VETH, */
-/* .netdev = { */
-/* .flags = IFF_UP, */
-/* .ifname = "br0", */
-/* .newname = "eth0", */
-/* .ipv4 = init_list(&veth.netdev.ipv4), */
-/* .ipv6 = init_list(&veth.netdev.ipv6), */
-/* }, */
-/* }; */
-/* vethlist.elem = &veth; */
-
-/* list_add(&veth.netdev.ipv4, &l1); */
-/* list_add(&veth.netdev.ipv4, &l2); */
-/* list_add(&veth.netdev.ipv6, &l4); */
-
-/* struct network veth2 = { */
-/* .type = VETH, */
-/* .netdev = { */
-/* .flags = IFF_UP, */
-/* .ifname = "br0", */
-/* .newname = "eth1", */
-/* .ipv4 = init_list(&veth2.netdev.ipv4), */
-/* .ipv6 = init_list(&veth2.netdev.ipv6), */
-/* }, */
-/* }; */
-/* list_add(&veth2.netdev.ipv6, &l3); */
-/* vethlist2.elem = &veth2; */
-
-/* struct network macvlan = { */
-/* .type = MACVLAN, */
-/* .netdev = { */
-/* .flags = IFF_UP, */
-/* .ifname = "eth0", */
-/* .ipv4 = init_list(&macvlan.netdev.ipv4), */
-/* .ipv6 = init_list(&macvlan.netdev.ipv6), */
-/* }, */
-/* }; */
-/* mclist.elem = &macvlan; */
-
-/* struct network macvlan2 = { */
-/* .type = MACVLAN, */
-/* .netdev = { */
-/* .ifname = "eth0", */
-/* .ipv4 = init_list(&macvlan2.netdev.ipv4), */
-/* .ipv6 = init_list(&macvlan2.netdev.ipv6), */
-/* }, */
-/* }; */
-/* mclist2.elem = &macvlan2; */
-
- struct lxc_netdev nd = {
- .ifname = "dummy0",
- .ipv4 = lxc_init_list(&nd.ipv4),
- .ipv6 = lxc_init_list(&nd.ipv6),
- };
- struct lxc_list ndlist = lxc_init_list(&ndlist);
- ndlist.elem = &nd;
-
- struct lxc_network phys = {
- .type = PHYS,
- .netdev = lxc_init_list(&phys.netdev),
- };
- phylist.elem = &phys;
-
- struct lxc_conf lxc_conf = {
- .networks = lxc_init_list(&lxc_conf.networks),
- .rootfs = "/mnt/iso",
- };
-
- lxc_list_add(&phys.netdev, &ndlist);
-
-/* list_add(&lxc_conf.networks, &vethlist); */
-/* list_add(&lxc_conf.networks, &mclist); */
- lxc_list_add(&lxc_conf.networks, &phylist);
-/* list_add(&lxc_conf.networks, &mclist); */
-/* list_add(&lxc_conf.networks, &vethlist2); */
+ struct lxc_conf lxc_conf;
while ((opt = getopt(argc, argv, "n:")) != -1) {
switch (opt) {
@@ -164,6 +56,8 @@ int main(int argc, char *argv[])
if (!name)
usage(argv[0]);
+ lxc_conf_init(&lxc_conf);
+
if (lxc_create(name, &lxc_conf)) {
fprintf(stderr, "failed to create the container %s\n", name);
return 1;
diff --git a/test/lxc_monitor.c b/test/lxc_monitor.c
deleted file mode 100644
index a5a3f4a..0000000
--- a/test/lxc_monitor.c
+++ /dev/null
@@ -1,99 +0,0 @@
-/*
- * lxc: linux Container library
- *
- * (C) Copyright IBM Corp. 2007, 2008
- *
- * Authors:
- * Daniel Lezcano <dlezcano at fr.ibm.com>
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
- * License as published by the Free Software Foundation; either
- * version 2.1 of the License, or (at your option) any later version.
- *
- * This library is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- * Lesser General Public License for more details.
- *
- * You should have received a copy of the GNU Lesser General Public
- * License along with this library; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-#include <stdio.h>
-#include <unistd.h>
-#include <string.h>
-#include <libgen.h>
-
-#include <lxc/lxc.h>
-
-void usage(char *cmd)
-{
- fprintf(stderr, "%s <command>\n", basename(cmd));
- fprintf(stderr, "\t -n <name> : name of the container\n");
- _exit(1);
-}
-
-int main(int argc, char *argv[])
-{
- char opt;
- char *name = NULL;
- int fds[2];
- pid_t pid;
-
- while ((opt = getopt(argc, argv, "n:")) != -1) {
- switch (opt) {
- case 'n':
- name = optarg;
- break;
- }
- }
-
- if (!name)
- usage(argv[0]);
-
- if (pipe(fds)) {
- perror("pipe");
- return 1;
- }
-
-
-
- pid = fork();
- if (pid < 0) {
- perror("fork");
- return 1;
- }
-
- if (!pid) {
- close(fds[0]);
- if (lxc_monitor(name, fds[1])) {
- fprintf(stderr, "failed to monitor %s\n", name);
- return 1;
- }
-
- return 0;
- }
-
- close(fds[1]);
-
- for (;;) {
- int err, state;
-
- err = read(fds[0], &state, sizeof(state));
- if (err < 0) {
- perror("read");
- return 1;
- }
-
- if (!err) {
- printf("container has been destroyed\n");
- return 0;
- }
-
- printf("container has changed the state to %d - %s\n",
- state, lxc_state2str(state));
- }
-
- return 0;
-}