aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrian Nord <nightnord@gmail.com>2009-11-17 10:56:23 +0100
committerDaniel Lezcano <dlezcano@fr.ibm.com>2009-11-17 10:56:23 +0100
commitaef4ebcf22406cb0b14fe0dd32acf3b936522d5e (patch)
tree8d9000013c96d2bee37ea19bf0f7c96e844b7f83
parentcleanup <lxc/lxc.h> (diff)
downloadlxc-aef4ebcf22406cb0b14fe0dd32acf3b936522d5e.tar.gz
lxc-aef4ebcf22406cb0b14fe0dd32acf3b936522d5e.tar.bz2
lxc-aef4ebcf22406cb0b14fe0dd32acf3b936522d5e.zip
Choose configuration directory
Maybe it will be more logical to keep configs into /etc/lxc/? Or, maybe, just use --with-config-path=/some/path switch into configure, which could be overridden as user wants to? Something like this one (in assumption, that this is up to user to create corresponding directory): Signed-off-by: Andrian Nord <NightNord@gmail.com> Signed-off-by: Daniel Lezcano <dlezcano@fr.ibm.com>
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2713053..4be78a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,9 +39,15 @@ AS_AC_EXPAND(LIBEXECDIR, $libexecdir)
AS_AC_EXPAND(SYSCONFDIR, $sysconfdir)
AS_AC_EXPAND(DATADIR, $datadir)
AS_AC_EXPAND(LOCALSTATEDIR, $localstatedir)
-AS_AC_EXPAND(LXCPATH, "${localstatedir}/lib/lxc")
-AS_AC_EXPAND(LXC_GENERATE_DATE, "$(date)")
+AC_ARG_WITH([config-path],
+ [AC_HELP_STRING(
+ [--with-config-path=dir],
+ [lxc configuration repository]
+ )], [], [with_config_path="${localstatedir}/lib/lxc"])
+
+AS_AC_EXPAND(LXC_GENERATE_DATE, "$(date)")
+AS_AC_EXPAND(LXCPATH, "${with_config_path}")
AH_TEMPLATE([LXCPATH], [lxc configuration repository])
AH_TEMPLATE([LXCLIBEXECDIR], [lxc executable library path])
AC_DEFINE_UNQUOTED(LXCPATH, "$LXCPATH")