summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@tuffmail.com>2013-12-12 10:24:50 -0500
committerBrian Evans <grknight@tuffmail.com>2013-12-12 10:24:50 -0500
commit1477b8961894eccd115c16dbaa4548bb0eadb82e (patch)
tree1171faa0ba0413306dcf6f527ecd412a86798203
parentRespin min/max patch for 5.1.73 (diff)
downloadmysql-extras-1477b8961894eccd115c16dbaa4548bb0eadb82e.tar.gz
mysql-extras-1477b8961894eccd115c16dbaa4548bb0eadb82e.tar.bz2
mysql-extras-1477b8961894eccd115c16dbaa4548bb0eadb82e.zip
Fix bad Makefile.am references in unittest/my_decimal
-rw-r--r--00000_index.txt5
-rw-r--r--20005_all_mysql-unittest-5.1.73.patch19
2 files changed, 24 insertions, 0 deletions
diff --git a/00000_index.txt b/00000_index.txt
index 0524cfc..98fcae7 100644
--- a/00000_index.txt
+++ b/00000_index.txt
@@ -1544,3 +1544,8 @@
@pn mariadb
@pn mariadb-galera
@@ Filter out -flto -fuse-linker-plugin -g and -Werror for tokudb
+
+@patch 20005_all_mysql-unittest-5.1.73.patch
+@ver 5.01.73.00 to 5.01.99.99
+@pn mysql
+@@ Fix poor Makefile.am references in unittest/my_decimal
diff --git a/20005_all_mysql-unittest-5.1.73.patch b/20005_all_mysql-unittest-5.1.73.patch
new file mode 100644
index 0000000..59cef0d
--- /dev/null
+++ b/20005_all_mysql-unittest-5.1.73.patch
@@ -0,0 +1,19 @@
+--- a/unittest/my_decimal/Makefile.am 2013-12-12 09:37:48.508314567 -0500
++++ b/unittest/my_decimal/Makefile.am 2013-12-12 09:38:28.187519854 -0500
+@@ -18,11 +18,11 @@
+ AM_CPPFLAGS += -I$(top_srcdir)/sql
+
+ LDADD = $(top_builddir)/unittest/mytap/libmytap.a \
+- $(top_builddir)/mysys/libmysys.a \
+- $(top_builddir)/strings/libmystrings.a \
+- $(top_builddir)/dbug/libdbug.a \
+- $(top_builddir)/mysys/libmysys.a \
+- $(top_builddir)/strings/libmystrings.a
++ $(top_builddir)/mysys/libmysys.la \
++ $(top_builddir)/strings/libmystrings.la \
++ $(top_builddir)/dbug/libdbug.la \
++ $(top_builddir)/mysys/libmysys.la \
++ $(top_builddir)/strings/libmystrings.la
+
+ my_decimal_t_SOURCES = my_decimal-t.cc
+