aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2015-06-27 20:20:04 -0400
committerTim Harder <radhermit@gmail.com>2015-06-27 21:14:08 -0400
commite3d0863d39fa056feb3123160561544319540501 (patch)
tree2ea0d0690366d8aec6c2b0678427c293f2307316
parentportage_conf: return priority ordered dict from load_repos_conf() (diff)
downloadpkgcore-e3d0863d39fa056feb3123160561544319540501.tar.gz
pkgcore-e3d0863d39fa056feb3123160561544319540501.tar.bz2
pkgcore-e3d0863d39fa056feb3123160561544319540501.zip
portage_conf: explicitly load required modules
It's not worth demandloading modules that will almost always be needed. Some of these are always needed now that we require repos.conf to exist.
-rw-r--r--pkgcore/ebuild/portage_conf.py11
1 files changed, 4 insertions, 7 deletions
diff --git a/pkgcore/ebuild/portage_conf.py b/pkgcore/ebuild/portage_conf.py
index b97f05a02..93f11948e 100644
--- a/pkgcore/ebuild/portage_conf.py
+++ b/pkgcore/ebuild/portage_conf.py
@@ -15,24 +15,21 @@ __all__ = (
from collections import OrderedDict
import os
-from snakeoil.compatibility import raise_from, IGNORED_EXCEPTIONS
+from snakeoil.bash import read_bash_dict
+from snakeoil.compatibility import raise_from, ConfigParser, IGNORED_EXCEPTIONS
from snakeoil.demandload import demandload
from snakeoil.mappings import ImmutableDict
from snakeoil.osutils import access, normpath, abspath, listdir_files, pjoin, ensure_dirs
from pkgcore import const
from pkgcore.config import basics, configurable
-from pkgcore.ebuild import const as econst
+from pkgcore.ebuild import const as econst, profiles
from pkgcore.ebuild.repo_objs import RepoConfig
from pkgcore.pkgsets.glsa import SecurityUpgrades
demandload(
'errno',
- 'snakeoil.bash:read_bash_dict',
- 'snakeoil.compatibility:ConfigParser',
- 'snakeoil.xml:etree',
'pkgcore.config:errors',
- 'pkgcore.ebuild:profiles',
'pkgcore.fs.livefs:iter_scan',
'pkgcore.log:logger',
)
@@ -267,7 +264,7 @@ def make_cache(config_root, repo_path):
def load_make_conf(vars_dict, path, allow_sourcing=False, required=True,
- incrementals=False):
+ incrementals=False):
sourcing_command = None
if allow_sourcing:
sourcing_command = 'source'