aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libqtxdg/libqtxdg-9999.ebuild13
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-9999.ebuild5
-rw-r--r--x11-themes/lxqt-themes/lxqt-themes-9999.ebuild9
3 files changed, 14 insertions, 13 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-9999.ebuild b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
index 67317650..936e7f64 100644
--- a/dev-libs/libqtxdg/libqtxdg-9999.ebuild
+++ b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils virtualx
@@ -20,6 +20,10 @@ LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
SLOT="0"
IUSE="test"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-qt/qttest:5 )
+"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -29,10 +33,7 @@ RDEPEND="
dev-qt/qtxml:5
x11-misc/xdg-utils
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-qt/qttest:5 )
-"
+DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-9999.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-9999.ebuild
index da7c6f4f..b81117b0 100644
--- a/dev-util/lxqt-build-tools/lxqt-build-tools-9999.ebuild
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit cmake-utils
DESCRIPTION="LXQt Build tools"
diff --git a/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild b/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
index 4760bcad..d02ca8d5 100644
--- a/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
+++ b/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -19,7 +19,6 @@ fi
LICENSE="LGPL-2.1+"
SLOT="0"
+BDEPEND=">=dev-util/lxqt-build-tools-0.5.0"
RDEPEND="!lxqt-base/lxqt-common"
-DEPEND="${RDEPEND}
- >=dev-util/lxqt-build-tools-0.5.0
-"
+DEPEND="${RDEPEND}"