aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2016-01-18 13:33:06 +0100
committerHorea Christian <h.chr@mail.ru>2016-01-18 13:33:06 +0100
commit40538baa57871ca325a0f077ba4d110cc3060491 (patch)
tree597cb92080b20af764d69b25751bf85ca7d1edb8
parentUpdate local USE description (diff)
downloadsci-40538baa57871ca325a0f077ba4d110cc3060491.tar.gz
sci-40538baa57871ca325a0f077ba4d110cc3060491.tar.bz2
sci-40538baa57871ca325a0f077ba4d110cc3060491.zip
sci-biology/psychopy: version bump
Package-Manager: portage-2.2.26
-rw-r--r--sci-biology/psychopy/psychopy-1.83.03.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/psychopy/psychopy-1.83.03.ebuild b/sci-biology/psychopy/psychopy-1.83.03.ebuild
new file mode 100644
index 000000000..b773ea5bd
--- /dev/null
+++ b/sci-biology/psychopy/psychopy-1.83.03.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils distutils-r1 git-r3
+
+DESCRIPTION="Python experimental psychology toolkit"
+HOMEPAGE="http://www.psychopy.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/psychopy/psychopy.git"
+EGIT_COMMIT="1.83.03x"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[lapack,${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s scalable psychopy/monitors/psychopy-icon.svg psychopy.svg
+ make_desktop_entry psychopyApp.py PsychoPy psychopy
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}