summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hd-idle/hd-idle-1.01.ebuild')
-rw-r--r--sys-apps/hd-idle/hd-idle-1.01.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/hd-idle/hd-idle-1.01.ebuild b/sys-apps/hd-idle/hd-idle-1.01.ebuild
new file mode 100644
index 000000000..ebfbaf485
--- /dev/null
+++ b/sys-apps/hd-idle/hd-idle-1.01.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="http://hd-idle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ dosbin hd-idle || die "dosbin failed"
+ newinitd "${FILESDIR}"/hd-idle-init hd-idle || die "newinitd failed"
+ newconfd "${FILESDIR}"/hd-idle-conf hd-idle || die "newconfd failed"
+}
+
+pkg_postinst() {
+ if [ ! -f /proc/diskstats ]
+ then
+ ewarn "Please note that hd-idle uses /proc/diskstats to read disk"
+ ewarn "statistics. If this file is not present, hd-idle won't work."
+ ewarn "You should check your kernel configuration and make sure"
+ ewarn "it includes CONFIG_PROC_FS=y."
+ fi
+}