summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-02-11 10:55:53 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-11 11:13:22 +0100
commitf1aafdadf059b1a69318306ba7ad27441d13c9e2 (patch)
tree73c3e6ae50ca3967a00231aefdaf03e5bce64c47 /dev-tex
parentlicenses: remove unused TeX-collection (diff)
downloadtex-overlay-f1aafdadf059b1a69318306ba7ad27441d13c9e2.tar.gz
tex-overlay-f1aafdadf059b1a69318306ba7ad27441d13c9e2.tar.bz2
tex-overlay-f1aafdadf059b1a69318306ba7ad27441d13c9e2.zip
dev-tex/minted: new package, add 2.9
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/minted/Manifest1
-rw-r--r--dev-tex/minted/metadata.xml23
-rw-r--r--dev-tex/minted/minted-2.9.ebuild39
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-tex/minted/Manifest b/dev-tex/minted/Manifest
new file mode 100644
index 0000000..26255c4
--- /dev/null
+++ b/dev-tex/minted/Manifest
@@ -0,0 +1 @@
+DIST minted-2.9.tar.gz 923928 BLAKE2B e4a9dc6194c8f03ce09d02cbab81f3aca473240ad6f84d6d39d7af62dc6111c50bdf2011ce1174d8bf998e93fab2706d7394423ee0a5486e92d62b592dca37ff SHA512 55b2d9800c752e47c98045baae0e68c3d5003f9154ec58d10922f1087cabb1305fbda9a3d45e330a8de982de1c94e58cbd1d3878f7f0cc8f5830080688e35377
diff --git a/dev-tex/minted/metadata.xml b/dev-tex/minted/metadata.xml
new file mode 100644
index 0000000..b60806a
--- /dev/null
+++ b/dev-tex/minted/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ minted is a LaTeX package that facilitates expressive syntax highlighting
+ using the Pygments library. The package also provides options to customize
+ the highlighted source code output using fancyvrb.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/gpoore/minted/issues/</bugs-to>
+ <remote-id type="github">gpoore/minted</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tex/minted/minted-2.9.ebuild b/dev-tex/minted/minted-2.9.ebuild
new file mode 100644
index 0000000..52308c3
--- /dev/null
+++ b/dev-tex/minted/minted-2.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit latex-package
+
+DESCRIPTION="LaTeX package for source code syntax highlighting"
+HOMEPAGE="https://github.com/gpoore/minted/"
+SRC_URI="https://github.com/gpoore/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/source
+
+SLOT="0"
+LICENSE="|| ( BSD LPPL-1.3 )"
+KEYWORDS="~amd64 ~arm64 ~ppc ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/pygments
+ dev-texlive/texlive-latexextra
+"
+BDEPEND="doc? ( dev-texlive/texlive-fontsextra )"
+
+DOCS=( ../CHANGES.md ../README.md )
+
+src_prepare() {
+ default
+
+ rm "${S}"/${PN}.pdf || die
+}
+
+src_install() {
+ LATEX_DOC_ARGUMENTS="-shell-escape"
+
+ latex-package_src_install
+
+ use doc && latex-package_src_doinstall pdf
+}