aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config/webapp-config-1.50.18.1.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.18.1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.50.18.1.ebuild b/app-admin/webapp-config/webapp-config-1.50.18.1.ebuild
new file mode 100644
index 0000000..e96f126
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.18.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.18.ebuild,v 1.1 2011/02/04 18:45:13 robbat2 Exp $
+
+EAPI="3"
+
+inherit distutils eutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/proj/en/webapps/webapp-config.xml"
+SRC_URI="http://dev.gentoo.org/~blueness/webapp-config/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-text/xmlto"
+RDEPEND=""
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="WebappConfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.50.16-update-servers.patch"
+ # Do not build nor install eclass manual, bug 322759
+ rm -f doc/webapp.eclass.5*
+ sed -e '/MAN_PAGES/s/webapp.eclass.5//' \
+ -e '/HTML_PAGES/s/webapp.eclass.5.html//' \
+ -i doc/Makefile || die
+}
+
+src_compile() {
+ distutils_src_compile
+ cd "${S}"/doc
+ emake
+}
+
+src_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ python_convert_shebangs 2 "${ED}usr/sbin/webapp-config"
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc AUTHORS CHANGES
+ dodoc AUTHORS CHANGES
+ doman doc/webapp-config.5 doc/webapp-config.8
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" WebappConfig/tests/dtest.py
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+}