summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/rainbowcrack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/rainbowcrack')
-rw-r--r--app-crypt/rainbowcrack/Manifest2
-rw-r--r--app-crypt/rainbowcrack/metadata.xml14
-rw-r--r--app-crypt/rainbowcrack/rainbowcrack-1.5.ebuild46
3 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/rainbowcrack/Manifest b/app-crypt/rainbowcrack/Manifest
new file mode 100644
index 000000000000..51a1c562165d
--- /dev/null
+++ b/app-crypt/rainbowcrack/Manifest
@@ -0,0 +1,2 @@
+DIST rainbowcrack-1.5-linux32.zip 120118 SHA256 b1485f9131ee3a03006e269f674135a0a09cf4cb5465ab856565ce55a726ed55 SHA512 2c8663c7f6f2bc2ea6fbcb75710505705a290159cb6f8e58efc112eb5329c0be873e61636819ba7f8becf30b2dda2779aa3f2acd14e6c904962472c7833e7c6f WHIRLPOOL c8966033e255cef9ff4f84048c79c833f1791bfc54f784e936afc944ac4cef563b9ed3ab8f7e4911d83ede770422d5e5f99590d0824df790366c4e563664d635
+DIST rainbowcrack-1.5-linux64.zip 118000 SHA256 ebeaa84f01fd69e67670af47472f98e5d1c8b6b70f9590009b13956e859c4b5e SHA512 dd41ce2dd5a8209b445f0ee578892ab1236f7cc7a1a4404ab0e6c7eed0cc20168e039a063b08350d2ae42a25a9b6f7dd57c12fad7d480c302e28035f2582289e WHIRLPOOL 28259a3ef78d9d26b3cb0abcccf9d6efc05b999c38abcf5690b1b0fb9edf019a8c94d6f3ad6afe8c385fb92def3348bae214ecd57e0b70ef52edbc4138aef177
diff --git a/app-crypt/rainbowcrack/metadata.xml b/app-crypt/rainbowcrack/metadata.xml
new file mode 100644
index 000000000000..5e64af814596
--- /dev/null
+++ b/app-crypt/rainbowcrack/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<longdescription>
+RainbowCrack is a general propose implementation of Philippe Oechslin's faster time-memory trade-off technique.
+ In short, the RainbowCrack tool is a password cracker. A traditional brute force cracker try all possible
+plaintexts one by one in cracking time. It is time consuming to break complex password in this way. The idea of
+time-memory trade-off is to do all cracking time computation in advance and store the result in files so called
+"rainbow table". It does take a long time to precompute the tables. But once the one time precomputation is
+finished, a time-memory trade-off cracker can be hundreds of times faster than a brute force cracker, with the
+help of precomputed tables.
+</longdescription>
+</pkgmetadata>
diff --git a/app-crypt/rainbowcrack/rainbowcrack-1.5.ebuild b/app-crypt/rainbowcrack/rainbowcrack-1.5.ebuild
new file mode 100644
index 000000000000..83d126fca5e5
--- /dev/null
+++ b/app-crypt/rainbowcrack/rainbowcrack-1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Hash cracker that precomputes plaintext - ciphertext pairs in advance"
+HOMEPAGE="http://project-rainbowcrack.com/"
+SRC_URI="amd64? ( http://project-${PN}.com/${P}-linux64.zip )
+ x86? ( http://project-${PN}.com/${P}-linux32.zip )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RESTRICT="bindist mirror" #444426
+
+RAINBOW_DESTDIR="opt/${PN}"
+
+QA_FLAGS_IGNORED="${RAINBOW_DESTDIR}/.*"
+QA_PRESTRIPPED="${RAINBOW_DESTDIR}/.*"
+
+DEPEND="app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ mv ${P}-linux* "${S}"
+}
+
+src_install() {
+ local bin bins="rcrack rt2rtc rtc2rt rtgen rtsort"
+
+ exeinto "/${RAINBOW_DESTDIR}"
+ doexe alglib0.so ${bins}
+
+ for bin in ${bins}; do
+ make_wrapper ${bin} ./${bin} "/${RAINBOW_DESTDIR}" "/${RAINBOW_DESTDIR}"
+ done
+
+ insinto "/${RAINBOW_DESTDIR}"
+ doins charset.txt
+
+ dodoc readme.txt
+}