summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/paredit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/paredit')
-rw-r--r--app-emacs/paredit/Manifest1
-rw-r--r--app-emacs/paredit/files/50paredit-gentoo.el10
-rw-r--r--app-emacs/paredit/metadata.xml5
-rw-r--r--app-emacs/paredit/paredit-23-r1.ebuild23
4 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/paredit/Manifest b/app-emacs/paredit/Manifest
new file mode 100644
index 000000000000..77822c9c255e
--- /dev/null
+++ b/app-emacs/paredit/Manifest
@@ -0,0 +1 @@
+DIST paredit-23.tar.xz 24204 SHA256 c501d5a716258a6b6758cc40d3e12b3d7271e62b457202271402e8ad43053478 SHA512 33ae10d95d3b2d8fe2466fba20d6aa0abac56684807fb381ab0db2798e99e2358c6dca71794b95768b53be661b9181f458e932bb37c31ba7ebba155a57f1bb01 WHIRLPOOL 4e2f6ee89f6cf9edd4b0b88e03f8b26f288f646cca14324025d022d34d756e44cfb8bb8289345ca77f3bdeecc1d1c114c90a496d094149d4d0f59ce28affce93
diff --git a/app-emacs/paredit/files/50paredit-gentoo.el b/app-emacs/paredit/files/50paredit-gentoo.el
new file mode 100644
index 000000000000..a23e03ae81fa
--- /dev/null
+++ b/app-emacs/paredit/files/50paredit-gentoo.el
@@ -0,0 +1,10 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'paredit-mode "paredit"
+ "Minor mode for pseudo-structurally editing Lisp code." t)
+(let ((turn-on-paredit-mode (lambda () (paredit-mode 1))))
+ ;; some hooks: lisp-mode-hook and scheme-mode-hook are recommended
+ ;; in the paredit source code
+ (add-hook 'lisp-mode-hook turn-on-paredit-mode)
+ (add-hook 'scheme-mode-hook turn-on-paredit-mode)
+ (add-hook 'emacs-lisp-mode-hook turn-on-paredit-mode)
+ (add-hook 'slime-mode-hook turn-on-paredit-mode))
diff --git a/app-emacs/paredit/metadata.xml b/app-emacs/paredit/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/paredit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/paredit/paredit-23-r1.ebuild b/app-emacs/paredit/paredit-23-r1.ebuild
new file mode 100644
index 000000000000..9ec5d88766d8
--- /dev/null
+++ b/app-emacs/paredit/paredit-23-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Minor mode for performing structured editing of S-expressions"
+HOMEPAGE="http://mumble.net/~campbell/emacs/
+ http://www.emacswiki.org/emacs/ParEdit"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ dohtml *.html
+}